[resolved] Change of Server (9 posts)

  1. tobyb
    Posted 9 years ago #

    Hi there, have just moved servers, and the News section which I have created is now not working properly.

    I get the following error...


    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.


    Am really confused as to what to do next!



  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I would check that the mysql details have not been changed somehow - or your password maybe?

  3. nubricks
    Posted 9 years ago #

    OK I am at my wits end - Have followed all of your guides in order, Podz and I am having real problems. Have moved hosts today, trying to test on temporary domain host has given me but all I see is the template with no posts - message is 404 page.

    This is what I did - made backup, uploaded to new host, made sure I changed the wp config file and the did MYSQL import. When I click refresh on the temporary domain given to me i get the blog template with no posts.

    What I am unclear on is do I do a drop in the phpadmin on my old host. I didn't want to do that in case its all pear-shaped and then there is nothing live.

    If you are able to give me a call, I really need help - is there a private message option. My new host support is terrible - convenient after signing up!

  4. nubricks
    Posted 9 years ago #

    My apologies also I would please really appreciate any help, no matter how big there problem there is never a need to forget manners - sorry - Many thanks.Nubricks.

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Is there a /wp-content/cache directory?
    If there is, delete it.
    See what that does?

  6. nubricks
    Posted 9 years ago #

    Yes there is a cache on the temporary new host and in it there are 3 folders, index.php and wp_object_cache.lock - do i delete everything?

  7. nubricks
    Posted 9 years ago #

    I did what it said it your guide deleting the cache from both the local and remote host when I tried this whole process - it then didn't display anything. Can I send you a link to anything to help? Many thanks,

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    If you want to drop me an email with some details so I can see what the problem may be, sure.
    tamba2 at gmail dot com

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    For future searchers:

    3 steps:
    1. Use my guide and alter the 2 values to the new address
    ( http://www.tamba2.org.uk/wordpress/site-url/)
    2. Download wp-config.php and put this line inside the file:
    define('DISABLE_CACHE', true);
    3. Delete wp-content/cache.

    Do it in that order and you should be fine

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.