WordPress.org

Support

Support » How-To and Troubleshooting » Change from wp 1.2.2 to 1. 5 beta breaks

Change from wp 1.2.2 to 1. 5 beta breaks

  • Previous install was 1.2.2. It went in without a hiccup. Pulled its strings for a few days same result… worked flawlessly.

    Decided to up to the 1.5…snatched it for nightlys then dumped into dirs and hit the “upgrade.php” page and:

    Fatal error: Call to undefined function: __() in /www/xxx/xxxx/htdocs/blog/wp-admin/admin-functions.php on line 857

    I killed the dirs and database tables and did a fresh install of 1.5 and it installed without a hitch.

    Have no idea what happened just wanted to throw that seed out there incase it reared its head for others.

Viewing 15 replies - 1 through 15 (of 30 total)
  • the same happened with me. how can this be fixed?

    I’m getting the same error. No solution yet, as it seems. I will try to find a newer (or maybe older) version of the file in the CVS and see if i can get that one to work…

    TechGnome

    @techgnome

    Moderator

    When I upgraded this is how I did it and it seems to have worked:
    1) Made a backup of the database.
    2) Backed up the files from off of the web server
    3) Deleted all files & folders from the web site -left now with an empty web site
    4) Uploaded all the new files from the install.
    5) Ran wp-admin/upgrade.php
    6) Uploaded new template files
    7) browsed to the website, and verified the new site comes up.
    8) Made sure I could login to the admin area
    9) Double checked all my settings & made sure all was OK

    Tg

    It’s recommended that you DELETE your files on your server, not just copy over them using FTP. It is a known issue that on occasion, files do not get replaced properly, so it’s always better to clean out the files first.

    Well, i have just deleted everything from my server except for wp-config.php, uploaded the 1.5b1 stuff, called /wp-admin/upgrade.php — et voila, still the same fatal error. So thanks for your tips, but this was NOT it.

    I’m having the same problem with upgrading from WP122 to WP15b1.

    I have reported the bug to the Mosquito bugtracker and they’re working on it already…

    I had this problem but it dissappeared with the latest nightly.

    What’s the “latest” – 01-07 or 01-06? I tried it four times with 01-06 yesterday and don’t wanna do it again wih that one…

    1.2->nightly (2005-01-07) on Fedora Core 2.
    All I get for upgrade.php is a blank page. Something is working, since install.php tells me wp is already installed. I tried googling, found that the default had display_errors in /etc/php.ini turned off. Turned it on, but still no output. Any hints?

    I’m having the same error. I deleted all of my 1.2.1 install, and then put all of the nightly. blank upgrade.php, and same fatal error.

    any ideas?

    Scooter: details, details …… what ftp client are you using ? Is your name linked to the wp location ? Was everything working before you tried the upgrade ? Have you deleted and re-tried ?

    I suppose this is proof-positive that one wants to be careful moving from a stable version to a beta. It’s something that people should consider when wanting to move their production sites to a beta version. It’s often been said that it’s best to try this on a test site first, and then do the move.

    It gave me the error with admin-functions on 1-05, so I mowed through several older nightlies before trying 1-06 again. (Each time deleting the various wp files.) 1-06 worked for me.

    I was very careful to backup everything before all that though.

    My procedure to restore my database from Mingus (1.2.2) to the latest available version:

    1) Mingus is working fine
    2) Backup and another recommended stuff 😉
    3) Download nightile 1-04 and install it
    4) run the upgrade.php
    5) erase the 1-04 wordpress directory
    6) checkout the latest beta version

    Running the upgrade.php from 1-04 upgrade the database. In that way beta-1 don’t crash.

    That’s all!

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Change from wp 1.2.2 to 1. 5 beta breaks’ is closed to new replies.
Skip to toolbar