Support » Plugin: Eonet Manual User Approve » change admin receiver email setting missing

  • according the changelog this would have been fixed some versions ago, but yet in the latest version i miss to see where is the setting to change the admin’s email to a custom one?

Viewing 13 replies - 1 through 13 (of 13 total)
  • mupic


    I’m waiting for this too.



    Yes, this is crucial for me too.

    • This reply was modified 1 year ago by JustBruno.
    Plugin Author Alkaweb


    Hey guys!

    Sorry for the delay here. We did make an update last week and I will push another one next week.

    So, the setting is not working? Did you try the filter as well? With the latest version?

    If so, please send me the steps to reproduce the issue and I’ll fix it.

    Keep me posted ๐Ÿ™‚

    sorry @alkaweb, there’s no setting for changing the receiver email address, not in version 2.1.3, this is why it is not working.

    you can switch the “Send email to admin” toggle, you can change the subject, you can change the content, but you cannot actually specify “i want eonet to use this address as recipient of the new registration requests, instead of the main admin email address”.

    if there’s a filter to make that work, could you please post a sample here, so we can check it?

    many thanks!

    Plugin Author Alkaweb


    We can add an option, that’s a good idea. But did you try this filter:

    add_filter('eonet_mua_admin_notification_email', function() {
    return '';

    That should do the job fine ๐Ÿ™‚

    unfortunately not, it isn’t working for me.

    i added the filter function, then tried a new registration request, but the notification is still sent to the main admin email address.

    i wonder if @petrp, @waldub and @justbruno have tested it and with what results…

    We can add an option, thatโ€™s a good idea

    will this make it to the next update? and is there an ETA?

    I was looking for such a plugin, just for my needs, nice plugin.

    I’m waiting for that too.
    that’s so important to me.

    Sending to your own e-mail address, not just the administrator.

    This problem has already been asked here

    hello @alkaweb any more news on this issue?
    is there an option coming any soon?



    sorry @alkaweb my mistake, the filter

    add_filter('eonet_mua_admin_notification_email', function() {
    return '';

    seems to do the job!


    Hi, @maxgx and @alkaweb!
    Is it working? This additional filter…
    Where should I put this code?

    Many thanks!

    hi @barba-azul, place the script in functions.php of you theme.

    alternatively you may want to have a look at User Registration

    @alkaweb, would this code work for notifications to 2 emails?

    add_filter('eonet_mua_admin_notification_email', function() {
    return ',';


    • This reply was modified 6 months, 2 weeks ago by JustBruno.
Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘change admin receiver email setting missing’ is closed to new replies.