Change admin name when I post a comment (11 posts)

  1. nick74
    Posted 6 years ago #

    I hate when I post a comment it says "admin"

    Is there a way to change that?

  2. Jeremy Clark
    Posted 6 years ago #

    In the dashboard of your blog click on the link in the top right that says admin then in the next screen fill in the first name and last name the choose the display name you like.

  3. nick74
    Posted 6 years ago #

    awesome. and how would I add a default avatar to go with my name? right now there are no pics when I or anyone makes a post.

  4. nick74
    Posted 6 years ago #

    "As of WordPress 2.5, Gravatars are built-in" where do I find this?

  5. Further down.

    WordPress 2.5 marries theme authors and casual WordPress users together with support for Gravatars in the WordPress Administration Panels. Theme authors have an option to include Gravatars in their designs, and are recommended to do so. WordPress users can easily control their Gravatar usage in the Settings > Discussion Administration Panel.

  6. nick74
    Posted 6 years ago #

    I have Settings > Discussion Administration Panel set as

    Show Avatars
    G Rating
    Default Avatar - Mystery Man

    yet no avatars show when posts are made.

    I'm confused

  7. URL?

    Your theme may not be correctly set up for Gravatars. Try the default theme and see if that works. If so, you'll need to inspect the comments.php file for your theme to sort it out.

    (also you won't get a pretty gravatar until you sign up with your email address, just the normal mysteryman you have here).

  8. nick74
    Posted 6 years ago #


  9. Yeah, it's your theme.

    I THINK (based on http://wphacks.com/wordpress-25-how-to-add-gravatar-to-your-wordpress-theme/ ) that all you have to do is put this in your comment loop where you want the gravatars:

    <?php if(function_exists(’get_avatar’)){ echo get_avatar($comment, ‘50’);} ?>

    That said, it's probably a little more complicated to get it right (and I'm not the best themer in town).

    You also might want to consider upgrading to 2.8.6 (you're on 2.7.1 and the more out of date you get, the worse things can be)

  10. John Hoff
    Posted 6 years ago #

    Since your theme doesn't support them, you can try using a plugin to display them.

    Here's one: WP-Gravatar

    Here's another: Easy Gravatars

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.