WordPress.org

Forums

CGI Timeout (10 posts)

  1. thepsychicpilot
    Member
    Posted 8 years ago #

    "CGI Timeout
    The specified CGI application exceeded the allowed time for processing. The server has deleted the process."

    I last logged in to my site around 18:00 EST last night (11/19/06). I tried again around 10:00 this morning and I've been getting the above CGI Timeout error all day. I've searched the Codex and most of the posts reporting this problem are a year or two old. The responses point to an issue with a server host PHP upgrade. I've contacted my host and they say that they did run control panel updates yesterday, but no recent changes to PHP or MySQL servers which would cause a CGI Timeout. They restarted their MySQL servers for my site to try to resolve it, and the Timeout is still happening. They are currently running PHP 4.4 on a Windows 2000 Server. None of their other customers are reporting similar errors.

    Keep in mind that I am quite the novice at this. They suggest I create a test page, with the minimum amount of code necessary to demonstrate the server error and a link to the test page so they can investigate it further.

    So...I'm looking for any suggestions here. Can someone more versed in this explain to me what might be happening? Is it necessary to create a test page for my host (Servergrid) to research? If so, I have no idea how to do that, so any instruction on that would also be very helpful.

    Thanks for your help.

  2. thepsychicpilot
    Member
    Posted 8 years ago #

    Also, I'm getting this same error when I try to retrieve my WordPress password.

    I'm at a loss.

  3. muelheim
    Member
    Posted 8 years ago #

    CGI-Timeout?

    Do you have an url?

    Most servers limit the process-time for each access. Normally you get messages like that if you parse huge amounts of code or endless loops. Did you chenge anything of your code lately? Can you access other pages on the server? Do you run phpmyadmin?

    The first test would be a php-test, then a MySQL-Test.

  4. thepsychicpilot
    Member
    Posted 8 years ago #

    Thanks.

    The error occurs on my Login page: http://www.thepsychicpilot.com/wordpress/wp-login.php

    I enter my Username & ID. Click login and it hangs.

    I gave my host my username and password to test it. They were able to duplicate it. They reset the MySQL server and tried to login again, but got the same error. I added a couple of Plug-Ins yesterday that I didn't have any problem with and that worked fine. I logged out and back in at least once after that with no problem at all.

    I did do a backup last night using the default backup plug-in. Would that have something to do with it?

    Like I said, I'm a novice at this. What do you mean by "parse huge amounts" of code and "endles loops"?

    They want me to set up a test page for them to check. I have no clue how to do that.

  5. Chris_K
    Member
    Posted 8 years ago #

    Just for grins...

    FTP to your site and delete/move out those new plugins from the wp-content/plugins directory. WP will detect they're gone and disable them.

    Does that change anything?

  6. thepsychicpilot
    Member
    Posted 8 years ago #

    I'm home now and am trying it from my home computer as opposed to my work computer. I have auto complete on here at home, so it remembers my password and logs right in. Maybe it's a coincidence now, but I am going to try it at work again tomorrow and see what happens. Maybe something has changed since then. I also deleted the Plug-Ins from my FTP, after I came home and logged on. I'll check back here tomorrow and let you know the outcome.

    Thanks for the help.

  7. thepsychicpilot
    Member
    Posted 8 years ago #

    Well, I deleted all of the Plug-ins that I uploaded last week. That seems to have fixed the CGI Timeout problem. Now, however, I've run into another problem. This time, it's with my editor. I was using the default WordPress editor (the rich-text one, with all the pretty icons and stuff). Now, it's showing up as a basic editor that is much more difficult to use (for me, anyway). Is there a way to switch it back? I haven't searched the Codex for that problem yet, but wanted to post it here to see if it might be related.

    Thanks.

  8. Chris_K
    Member
    Posted 8 years ago #

    First, ensure you haven't disabled javascript in your browser.

    To toggle the WYSIWYG, visit Users -> Your Profile. Scroll down and toggle the bottom-most checkbox.

  9. thepsychicpilot
    Member
    Posted 8 years ago #

    FYI:I am using IE. In Writing Options>Formatting on the Dashboard, I have "Users should use the visual rich editor by default" checked and I am not seeing a rich editor.

  10. thepsychicpilot
    Member
    Posted 8 years ago #

    I just found that in another Codex and it worked. Thanks Handy.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags