WordPress.org

Support

Support » Plugins and Hacks » CGI script: zend_mm_heap corrupted

CGI script: zend_mm_heap corrupted

  • utnalove
    Participant

    @utnalove

    Hello, many users notified me that they cannot browser the site.
    They see this error: CGI script: zend_mm_heap corrupted

    Sometimes I also see this error, but sometimes when I click “refresh” on the browser the page shows up.

    What’s wrong?

Viewing 10 replies - 1 through 10 (of 10 total)
  • This is really an internal server error. Not much to do with W3TC. I would suspect a misconfigured php.ini file. You should contact your host.

    utnalove
    Participant

    @utnalove

    It happens only when the W3TC is ON…. they are not so helpful :/
    Please tell me what else they can check.

    Please note that this is not Apache. This is another web server that should work like Apache. But there are some minimal differences.

    tgeorge
    Member

    @tgeorge

    Do you have access to your “php.ini” file? If yes, you could try one of the solutions provided here (they involve editing “php.ini”):

    http://stackoverflow.com/questions/2247977/what-does-zend-mm-heap-corrupted-mean

    Also, you should check your “error_log”, if you have access to it. It can give you more details on the error.

    utnalove
    Participant

    @utnalove

    I do not have access to the php.ini, but my hosting provider told me that I can change some values creating a new empty php.ini.

    Maybe if I give you access to my phpinfo(), you can check if there is something wrong with the default configuration?

    P.s. I have checked the HTTP log and PHP log and nothing helps. Cannot find errors related ot zend or cache. Maybe some other logs to check?

    utnalove
    Participant

    @utnalove

    Hello, please help….

    Plugin Author Frederick Townes
    Member

    @fredericktownes

    Are there no other errors in your error log that would be helpful?

    utnalove
    Participant

    @utnalove

    no, that’s all. I have noticed that this error appears also when other cache plugins are enabled or just installed. With W3 Total Cache always. With other plugins sometimes on some posts or pages.

    Plugin Author Frederick Townes
    Member

    @fredericktownes

    SO should be helpful here.

    utnalove
    Participant

    @utnalove

    yeah it should, I remember I tried all of the suggestions without success

    Plugin Author Frederick Townes
    Member

    @fredericktownes

    I’m sorry, can you ask your host?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘CGI script: zend_mm_heap corrupted’ is closed to new replies.