Support » Installing WordPress » CGI Script Error?

  • I don’t get it. I’ve never seen a problem like this, and I guess this is why I know I’m still green. I set up my config file, and then I got this error before the installer ran:

    CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers.

    Can anyone tell me what this might be? Check me online at
    http://www.carigblog.com/index.php

Viewing 15 replies - 16 through 30 (of 36 total)
  • Another comment here — tried commenting out line 163 in wp-includes/wp-db.php and retried the installation. Doing that resolved the CGI error message display, but it displayed the installation screen in an unproperly formatted mode, allowed entry of the Blog title and Your email fields, but when clicking on the Install WordPress button, it displayed an error page with the message “The page could not be found…(HTTP Error 404 – File or directory not found. Internet Information Services (IIS))”

    AWS

    (@adminreports)

    Make sure your temp and sessions directory is writable by NETWORK.

    Best way to cure it is to create C:\Inetpub\Temp and C:\Inetpub\Sessions and edit php session save path to the new sessions directory and temp to the new temp directory. Restart IIS to read the new config. This should stop the problem.

    Another thng is make sure
    cgi.force_redirect is set to 0 ,cgi.rfc2616_headers = 1, cgi.fix_pathinfo is set to 1.

    I can’t change server side, so I fixed this problem simply rewrite the wp-include/db.php like suggested here.

    But now the problem can be showed again on the next upgrade..

    Saw recently with one host, http://www.hostnexus.com, that with their Plesk control panel, they allowed PHP, via a check box, to run as an ISAPI extension. WordPress 2.3.3 installed just fine.

    Connecting the dots… http://trac.wordpress.org/ticket/5951

    What is unclear is why 2.3.3 is failing but earlier versions worked just fine. “Upgrading” to a Linux host isn’t an option if you also run other non-Linux applications on the server.

    On the same server 2.2.1 works correctly.

    I have encountered this issue as well on a Windows 2003 server. I operate the server (I am the host) and moving to Linux is not going to happen.

    – I can run phpinfo – no problem – PHP is running fine.

    – I have several (earlier version) instances of wordpress running on my server so I know WP is easy to install and use on Windows.

    – I note that whatever code was posted at this location no longer exists, so it is unclear what that solution looked like.

    – I have installed version 2.3.1 on this subject site and it worked just fine. Why does 2.3.3 have a problem, and does anyone have a definitive solution?

    Thanks!

    I second @gbdg
    http://wordpress.pastebin.ca/893007no longer has the code we need

    can someone show us the code please?

    Ditto…I would also love to see the code we need.

    also, not only Installation of 2.3.3 will have this problem, but also 2.3.1 + permlink will have the same error msg

    meaning I can install 2.3.1 and make wordpress up-n-running, but if I enable permlink, then visit a post using its permlink, I will hit the same error as OP

    MichaelH

    (@michaelh)

    jsnielsen – can your host run PHP as an ISAPI extension?

    Also, thanks to webdesigner and gary I’ve attached the ‘purported to work wp_db.php code’ at trac. Again, that code may or may not work.

    Thank you for your persistence in this matter and we’ll look forward to hearing your results.

    jsnielsen

    (@jsnielsen)

    Michael, don’t know if they can.

    I’ll see if I can get your code to work.

    jsnielsen

    (@jsnielsen)

    Hey Michael,

    unfortunately it didn’t work. After I upload it, I get the error:

    PHP Warning: require_once(D:\Domains\pipforhelvede.net\wwwroot\wp25/wp-includes/wp-db.php) [function.require-once]: failed to open stream: No such file or directory in D:\Domains\pipforhelvede.net\wwwroot\wp25\wp-settings.php on line 123 PHP Fatal error: require_once() [function.require]: Failed opening required ‘D:\Domains\pipforhelvede.net\wwwroot\wp25/wp-includes/wp-db.php’ (include_path=’.;C:\php5\pear’) in D:\Domains\pipforhelvede.net\wwwroot\wp25\wp-settings.php on line 123

    jsnielsen

    (@jsnielsen)

    Ok, I guess what I’d really like to get answered right now is this:

    – Is this error something the WP people is taking care of, or is this considered an IIS thing, with no subsequent responsibility for/from the WP people ?

    – Is this an error being looked into for a fix ?

    – If the WP people are working on a fix for this, what’s the ETA ? (If anyone knows)

    It’s a bleeding shame, WP has all I need, but I need to move on to e.g. Joomla or something, if this issue isn’t really being worked on, since I can’t really change the way my host is running their software.

    Then I have to change hosts too, and I then lose the ability to do asp.net and possibly Ruby soon.

    jsnielsen

    (@jsnielsen)

    Amazing how oblivious the devs can be.

    Guess it’s true then… open source = no responsibility = !”#! the user, when things go haywire.

    Guess I’ll just stay on Joomla then.

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘CGI Script Error?’ is closed to new replies.