[resolved] Cgi-problems when visiting settings-permalinks page (1 post)

  1. SEOguruNL
    Posted 3 years ago #

    Every time I visit the Setting-Permalinks page (in my admin dashboard) my .cgi-pages (I have several .cgi scripts in my site as well) are unreachable. I get the error message: "CGIWrap Error: Script dir not found". Apparently, visiting the permalinks-page (just visiting, I'm not even changing or saving anything there) is doing something with the .htaccess, because when I then overwrite it with my local .htaccess everything works fine again. When I compare the remote and local .htaccess they are exactly the same. Also the permissions of the remote file is unchanged (644).

    I have installed my wordpress in my /seo-blog/-directory and recently I changed the Site address (URL) to the root (/). I'm using permalinks with a custom structure: /seo-blog/%postname%/. My .htacsess contains more than just the wordpress code. At the moment the wordpress code looks like this:

    Options +FollowSymLinks
    <IfModule mod_rewrite.c>
    RewriteBase /
    RewriteCond %{HTTP_HOST} ^seoguru.nl [NC]
    RewriteRule ^(.*)$ http://www.seoguru.nl/$1 [L,R=301]

    In the /seo-blog/ dir there is also a second .htaccess with just this code:

    Options +FollowSymLinks
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    I also recently started using the Graphene theme and updated wordpress. Can anybody see what the problem might be? Thanks a lot!

Topic Closed

This topic has been closed to new replies.

About this Topic