Support » Fixing WordPress » CGI error

  • Came in to work today and am now unable to access my blog via HTML, looks like plain text, and when I try to access wordpress, I get this error:

    The specified CGI application misbehaved by not returning a complete set of HTTP headers.

    Any help would be appreciated. Here is a link to my blog if that helps:


Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Mark Ratledge


    Forum Moderator

    Did you change your site or blog URL in settings yesterday? Like add the index.php to your settings? If not, someone changed something on your windows server, i.e. the server that runs the main site photoonesoftware, and that could have been directory permissions, .htaccess (if the server is configured for .htaccess) or something else. Good idea is to talk to whoever administers the main site.

    This is doing my head in!

    I am new to wordpress and have just installed wp 2.9.2 and right from the outset I am getting “The specified CGI application misbehaved by not returning a complete set of HTTP headers”

    I was not to bothered to begin with. I thought that the forum would help me. I have tried several of the suggestions from changing the php version from 5x to 4x, removing the ./ or was it the /. from the index.php file and even changing the code in wp-db.php file. Nothing worked at all. Anyway I have reinstated it back to how it was and started a new cgi error search.

    The penny then dropped that this error has been around for at least 2 years for loads of people.

    Can one of the developers please help? Surely there must be a solution to this. I am not an expert in php at all but I am not daft. I am an end user trying to use a well praised piece of software. I would like to use it but do not know where to look next.

    Please help

    Kind Regards
    Uncle Tom


    I have been in touch with my host company and they came back with the answer within 4 hours.

    Their answer was “You are getting that error due to your permalinks settings in your WordPress configuration. You sohuld be able to turn these off. Permalinks require mod_rewrite which isn’t available on Windows. It is a Linux/Apache function only I’m afraid.”

    When I reset the permalinks to default all was fixed. So if you are on a Windows platform then permalink default would seem to be your only option.

    I trawled the help forum and the WP documentation and at no point did I find any reference to platform capabilities. That’s not to say its not there just that I did not find it. In my humble opinion the permalink settings page should highlight the options by platform. Just a thought.

    Now I have it working its a great product.

    My hosting company is straight up and down and do what a lot of company’s don’t which is talk to end users not just techies. They also provide a service which in my experience is not that common. They are

    Kind Regards
    Uncle Tom

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘CGI error’ is closed to new replies.