Support » Plugins » CG-PowerPack 1.5a8 is up for all…

  • The usual place:

    Cut from the CHANGES.TXT file:
    – CSS class .cgfeed now wrappers any given feed that’s output
    – new wrapper div around title graphic for positioning/CSS
    – updated cgfeeds.php sample page for incorporating an ‘independent’ page with newsfeeds into your overall site/theme.

    – added support for new stores US & Intl
    – added improved support for Wishlist lookups
    – fixed bugs in AssociateID assignment
    – new cga-config controls over Wishlist output fields
    – better error handling when cache files can’t be written to.
    – fixed bug in annotation/note output

    – new three-dashes-is-spam domain name check — rather eat the false-positive once in a while, and pre-catch spammers better. This will eventually go into my ‘graylist’ moderation system…
    – lots of code cleanup, removing unused portions
    – heavy optimization of the flushbots and purge processes, good when you need to clean out 100K entries… 😉

    – catching latest spammers, another few dozen entries both domains and keywords
    – added two worm-bots to the excluded bot list

    – support for WinAmp “Now Playing” plugin’s HTTP POST blogging.
    – trying to reorder when to strip slashes from incoming text, as some people seeing slashes stored in tracktunes.txt, which is incorrect.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Have people installed the new version? I’m especially interested in hearing from CG-Amazon people using wishlists, CG-Referrer folks where the spammers should be being caught more automagically now (some will still get through), CG-AntiSpam (which needs more testing from people with minimal ‘real’ comments — for safety), and people using Now Playing + CG-WhatTunes.

    Post away with your experiences, questions, thoughts, etc.


    Okidoki! I can start to test this now that all of my company has left. I know I volunteered to do so before, David and sorry I haven’t gotten around to it. The timing hit when I had a month full of company streaming through my house.

    Before I proceed, though, I have a question. I had downloaded what you had provided as an update in February. The version I installed (but haven’t set up yet) was 1.5b1, which to me implies beta. I notice the version you indicate in this thread is 1.5a8. Does the “a” and “b” indicate alpha and beta? Please clarify the latest version.

    1.5a8 is the latest — b1 should have been a1… I’m just indicating ‘alpha’ for the moment, but in fact most everything seems ‘release stable’ aside from not having enough testing on CG-AntiSpam (I need a ‘test site’ that’s getting a lot of comment & trackback spam willing to be a guinea-pig…), and I know that CG-Referrer could use some more admin pages…


    Okay — I’m starting to test. I’ve installed and activated only the Amazon plugin so far. The plugin is activated and I do get a CGA option at the top of my admin screen but when I click on it, it is looking for the files here:

    Not Found
    The requested URL /photoblog/wp-admin/cg-plugins/cga-admin.php was not found on this server.

    I believe this is the way you used to have the files be located (in a special cg-plugins folder in the admin folder) so I’m not certain what needs to be changed here and how.

    Update: same goes for CG-Referrer.

    Ummm. This is with 1.5 release? Or earlier (or later)?

    I have 1.5 right here, link hover goes to:

    Not sure what’s up on your site… but want to debug through it, as this sounds odd. I’m running release 1.5 (not newer code), and working fine, but possible that they’ve been tinkering with the menu system in newer code or something…


    I’m using the initial release of 1.5 without any additional WP updates.

    All I know is that when I click on CGA in the admin area it tries to find it here:


    The plugins list indicates I’ve installed CG powerpack version 1.5b1 even though I downloaded 1.5a8 and was pretty sure I installed that one instead. I know I was about to test the earlier version (1.5b1) before personal life distractions. Let me check my database and reinstall from scratch to see if this takes care of it.

    Update #1:

    I don’t see any tables in mysql relating to cg-amazon, etc. so I’m not certain this portion of your install instructions applies to me:

    0. ALL DATABASE TABLE NAMES CHANGED — this occurred back in 1.5a6
    To better match multi-install scenarios, all the table names now use the wordpress prefix set
    for the given installation. SO YOU WILL NEED TO CHANGE THE TABLE NAMES MANUALLY.
    If you are a previous user upgrading, you’ll need to change your tables as follows:
    referer_visitlog => {your_wp_prefix}cg_referer cg_amazon => {your_wp_prefix}cg_amazon {your_wp_prefix}postrelated => {your_wp_prefix}cg_related This should hopefully make things MUCH easier for people in the future.

    Update #2:

    I believe my problem was that I copied over the entire plugins folder to the wp plugins folder instead of the contents. I had my files copied over like this:


    duh! It works now, thanks. 🙂

    Great product, David. I’ve tested and implemented it and here is what I encountered:

    1. When adding items to an existing category, the item is added but the blogcat remains blank. In order to assign, I edit the item to assign it to the category.

    2. When editing items, once changes are submitted, there is no “done” and “return” screen like there is when you add an item. In order to return to cg-amazon, you must click on the CGA link at the top of the admin screen.

    3. The new Amazon search feature you added in the admin interface is awesome! Enuff said.

    4. When checking, then adding checked items from an Amazon search the items are properly added to the selected blogcat (thank goodness — ’cause if we add a lot of items it would be tedious to edit each one to assign the category). Not sure why this works but doesn’t in item #1.

    Still testing and having fun — so this is what I’ve come up with so far. Great product, David.

    how exactly do I set up winamp’s now playing? using what was in the readme I get entries like this:

    %t %b %a %g 1113271970
    %t %b %a %g 1113272079
    %t %b %a %g 1113272129
    %t %b %a %g 1113272417

    iceman: should just work. make sure you have the new a8 powerpack, as that’s needed. the default POST settings in NowPlaying was tested and working in a8.

    Just my local experience here. I might need to figure out what’s diff about your setup that things aren’t the same:
    1. I just tested adding new item, with a new hand-typed category in one test, and picking from dropdown list in the other test. Both ended up properly ‘saved’ when I got back to the list.
    2. I just editing something, and it took me right back to the CGA main screen when I clicked ‘submit’. Can you go into edit mode, then bring up the source for the page, and look at what the form “edititem” action field’s URL is?
    3. That’s been there for a while, just gotten a bit better with the new Amazon interface. But people who haven’t used the system since real early haven’t seen the search-and-add, which is so useful…
    4. Yeah, that actually goes through the same code as the individual ADD, it just passes an array of products instead of a single one. Weird. May need to get a temp admin acct on your blog to see for myself if we can’t figure it out otherwise…

    Thanks for testing/feedback!



    We’ll definitely look into that. In the meantime, I’ve deactivated the plugin while I await help from the designer of the theme. The amazon items were running off the right column in the theme I’m using (

    I did want to mention that while I had it up and running, and even though I put in my own amazon affiliate code, only your code appeared every single time the page was refreshed. I have no problem displaying your code because you are the developer and make this for everyone for free, but would like to have my code appear for the percentage of time indicated in the script. Is this by design or a bug?

    Howdy. CG-Amazon is excellent (I threw it in a page template), though it occasionally pulls “phantom” items from my wishlist–as in, there’s nothing there. Well, now that I look, I see that the phantom items are gone. I guess it takes a daily wishlist update to fix them. 🙂 If you’re interested in seeing your code in action:

    I’m also using your feed reader to aggregate friends’ blogs:
    friends’ feeds and it’s working very nicely, too.

    A note about CG-Inline: I was using it, but it broke the XHTML validation on my pages… it replaced what should be the last < /p > with a < br/ > and a few div’s with the inline classes. Just FYI. I’ll probably try tweaking it myself to see if it works any better. If I get it resolved, I’ll let you know what it was about–or if it’s just the way it interacts with my theme. 🙂

    deb – see the other post for design stuff — drop me an email at the address there, and I can give you some ‘direct’ help.

    If you have an affiliate code in there, it should be reflecting it properly in 80% of the links. If I have direct access to the site to look at the css issues, I’ll double check that part is working properly at the same time…

    vcourtney – thanks for the feedback on CG-Amazon! yes, I haven’t spent a lot of time dealing with items removed from the wishlist (or other lists). That needs to go on a to-do list here. 😉 FYI, you (and anyone else showing pricing info) should call the show_amazon_disclaimers(); function somewhere, and need to allow timestamps on the output (which it should be showing automatically if prices are showing! weird…).

    Actually: DEB: if you look at her wishlist, you’ll see that only one out of every few items has my ID tagged on it… so it’s working there, must be something else on your site — again, I can look.

    Glad that CG-FeedRead is working well too. That’s a staple that I no longer use directly on my site, but might start using again once I code up the re-blogging support for posting into wordpress.

    Yeah, I admit I haven’t been working much to ensure CG-Inline retains XHTML validation (or any of the plugins necessarily) — I try to keep them clean, but sometimes I miss something. A lot of the tricky floats and stuff I do is actually ‘illegal’ xhtml code, but it works as designed in all the major browsers. go figger.

    CG-Inline should NEVER be replacing something that should be there — it only inserts itself into the block where the comment tag was. However, I guess if it was the very last thing in the post, something like that could happen — if that’s the case, put something, anything, after it and see what it does.


Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘CG-PowerPack 1.5a8 is up for all…’ is closed to new replies.