Support » Plugins » CG-FlashyTitles v1.1 (sIFR for WordPress)

  • I’ve just updated my WordPress Plugins Contest entries page with the new 1.1 release of the CG-FlashyTitles (sIFR) plugin. If you’ve had problems and were on 1.5 or 1.5.1, please give this a try — I just overhauled some of the menu-install code to hopefully have better backwards-compatability.

    In theory, the ‘function already defined’ stuff should now be gone, and the FlashyTitles main admin menu should now show up. Note that the FlashyTitles menu, when selected, only is ‘highlighted’ in and beyond (I think) — 1.5 and 1.5.1 don’t highlight custom top-level menus properly.

    Let me know if you have problems with this release, and I’ll try to figure it out. 😉


Viewing 15 replies - 1 through 15 (of 18 total)
  • Has anyone had a chance to give this new version a try? Especially those of you who had problems with earlier versions… 😉 Thanks!

    Just now saw this post David. I will redownload and check out over the next couple of days (around a writing deadline or so….)

    [BTW: I use a download “improver”, GetRight due to the fact that I have the world’s slowest dialup connection – over 30+ year old analog lines. On your site, I’m unable to use GetRight’s functionality due to the way you handle downloads. I’m NOT thrilled about that, no matter that your downloads tend to not be too large – regardless, a “plain” link to downloads would be much preferred.]


    Interesting that GetRight has any problems. I would think my approach would work transparently with most download apps, as I’m not trying to really obscure the downloads, just make sure it comes through my form & tracking process. But the download itself is launched via the browser, and I would have thought GetRight being assigned as the helper for say .zip files would do the trick. I used to hook GetRight into .pdf so that it wouldn’t use the in-browser viewer, which stinks.


    I use FF – GetRight only works “seamlessly” through FF as long as one can “copy link location”, which then opens the applet. Your setup won’t allow that….

    Hmmm… weird. I know old ‘freeware’ getright had problems with FF, but I haven’t used GR in at least two years now. That’s a shame — you should be able to assign .zip over to it, like I used to do with .pdf. Yeah, that was in IE back a few years, but it did the trick. I’ll look into this further — thanks for the heads up! 😉


    I just installed v1.1 to try it out. While it installed well and it does work, the load time on the pages goes down the toilet… What usually took 1/2 to 3 seconds to load takes anywhere from 10 to 20 seconds.

    The look is cool and all, but for performance, I’ll have to pass.

    Glad it installed and worked! 😉 😉

    Your site takes a little time to refresh as is, but yeah, not 10-20s. Admittedly, I haven’t tried it on a page with 33 titles — but I did test it with three fonts, one for title, one for two-per-page headlines, and one for all my sidebar titles (about 10 or so total).

    I’d love to know what’s your server (speed and connectivity), what’s your net connection, what browser do you use, what’s your machine, did you refresh/try a few times, what kind of caching (or non-caching) are you using in your browser, and what font were you trying? Maybe some of those answers would help — unsure.

    I’ve heard of wacky issues where the SWFs are actually loaded per-title. My understanding is that’s not typical behavior — but that’s the sort of thing which would explain a load time. You could check your logs, see if your browser requested the SWF 33 times in a row…

    I generally see my test pages load quickly, quick pause then to reload the titles, and not much other slowdown on load or scroll — though really ultra low-end machines might have some CPU hit.


    I’m currently running my own server. It’s a Celeron 2Gig with 2Gigs Ram, on a 100 meg managed switch. It’s running about 200 sites right now, so the speed of the server is a little slower than it could be. Oh, and it’s Window Small Business 2003.

    I’m using Firefox on workstations that are 1.5Gig to 3.8Gig. All of the machines take longer to load the page when FancyTitles is used. Sometimes it loads faster than others, and I’ve also noticed it’s now loading faster in all cases after I rebooted the server. There may have been an issus with the amount of free RAM.

    I will check the logs.

    I just noticed… if I have more than 1 “fancytitle”, and I delete one of them, they ALL go away and you have to re-enter the others.

    Well THAT would be a nasty bug! I haven’t seen that, but it is possible in fixing all the 1.5/1.5.1 backwards-compatibility stuff that I stomped on something and the delete process isn’t working as it should. I’ll go look right now! Thanks.


    Yep, there’s a typo. I need to re-activate all my debugging code darnit.

    For those of you with 1.1, line 424 of cg-flashytitles.php reads:
    if (!empty($sirfRep))
    and should read
    if (!empty($sifrRep))
    (the f and r are transposed…)

    That’ll keep it from deleting everything. 😉

    Thanks Hoover! Good catch.


    Fix works, thanks…

    let me know if you still see wacky performance problems… I’m sure the sIFR team needs more information. 😉


    Installed per instructions, no button installed despite the plugin showing up and my activating it. Any troubleshooting suggestions?

    the only known issue I’ve heard of either relate to:
    1. old versions of WP.
    2. another plugin doing something truly wacky and causing my menu to not show up.

    You can check the other thread:

    As to other plugins, I don’t know what might cause the issue. If you figure it out (turn off other plugins one at a time, until turning one off shows the FlashyTitles menu…), drop me an email direct at cgcode at chait dot net, and I can take a look.


    I’ll test the other plugins.

    In the meantime, where – specifically, not “in the WP admin panels” – should I see your button? What page or pages, and where on the page?



Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘CG-FlashyTitles v1.1 (sIFR for WordPress)’ is closed to new replies.