Support » Plugin: Custom Field Suite » CFS Plugin conflict with WP 4.9.1?

  • Resolved crystalsinger

    (@crystalsinger)


    My site seems to display just fine, but my WordPress dashboard interface had problems. I have eliminated all other plugins and the problem will repeatedly produce the same results when the Custom Field Suite plugin is enabled.

    I log in to my WordPress dashboard. I choose Pages from the menu, then select a page to edit. In the page editor, I can switch back and forth between the Visual and Text tabs as normal – Unless I click the update button while on the Text tab. Clicking update with the Text tab selected produces the following error (copied from my Chrome browser console):

    VM5855 post.php?post=48&action=edit:2131 Uncaught TypeError: Cannot read property 'indexOf' of undefined
        at HTMLDivElement.<anonymous> (VM5855 post.php?post=48&action=edit:2131)
        at Function.each (jquery.js:2)
        at jQuery.fn.init.each (jquery.js:2)
        at jQuery.fn.init.$.fn.init_wysiwyg (VM5855 post.php?post=48&action=edit:2102)
        at HTMLDocument.<anonymous> (VM5855 post.php?post=48&action=edit:2092)
        at i (jquery.js:2)
        at Object.fireWith [as resolveWith] (jquery.js:2)
        at Function.ready (jquery.js:2)
        at HTMLDocument.K (jquery.js:2)
    (anonymous)	@	VM5855 post.php?post=48&action=edit:2131
    each	@	jquery.js:2
    each	@	jquery.js:2
    $.fn.init_wysiwyg	@	VM5855 post.php?post=48&action=edit:2102
    (anonymous)	@	VM5855 post.php?post=48&action=edit:2092
    i	@	jquery.js:2
    fireWith	@	jquery.js:2
    ready	@	jquery.js:2
    K	@	jquery.js:2

    Once I’ve done this, it also causes the page editor to no longer switch back to the Visual tab from text. If I click on the Visual tab, the tab is highlighted, but nothing happens.

    Subsequently, if I navigate away from this page and then return to the page editor once this has happened, loading the page editor produces the following error:

    post.php?post=48&action=edit:2130 Uncaught TypeError: Cannot read property 'indexOf' of undefined
        at HTMLDivElement.<anonymous> (post.php?post=48&action=edit:2130)
        at Function.each (jquery.js:2)
        at jQuery.fn.init.each (jquery.js:2)
        at jQuery.fn.init.$.fn.init_wysiwyg (post.php?post=48&action=edit:2101)
        at HTMLDocument.<anonymous> (post.php?post=48&action=edit:2091)
        at i (jquery.js:2)
        at Object.fireWith [as resolveWith] (jquery.js:2)
        at Function.ready (jquery.js:2)
        at HTMLDocument.K (jquery.js:2)
    (anonymous)	@	post.php?post=48&action=edit:2130
    each	@	jquery.js:2
    each	@	jquery.js:2
    $.fn.init_wysiwyg	@	post.php?post=48&action=edit:2101
    (anonymous)	@	post.php?post=48&action=edit:2091
    i	@	jquery.js:2
    fireWith	@	jquery.js:2
    ready	@	jquery.js:2
    K	@	jquery.js:2

    There are other issues that this conflict produces as well. Once the issue begins, and for as long as the CFS plugin is enabled, I have problems using The Event Manager plugin also. When I select an event to edit, the Location and Organizers options, which normally have drop downs, no longer work, and loading that Edit Event page produces the following error:

    post.php?post=3249&action=edit:2790 Uncaught TypeError: Cannot read property 'indexOf' of undefined
        at HTMLDivElement.<anonymous> (post.php?post=3249&action=edit:2790)
        at Function.each (jquery.js:2)
        at jQuery.fn.init.each (jquery.js:2)
        at jQuery.fn.init.$.fn.init_wysiwyg (post.php?post=3249&action=edit:2761)
        at HTMLDocument.<anonymous> (post.php?post=3249&action=edit:2751)
        at i (jquery.js:2)
        at Object.fireWith [as resolveWith] (jquery.js:2)
        at Function.ready (jquery.js:2)
        at HTMLDocument.K (jquery.js:2)
    (anonymous)	@	post.php?post=3249&action=edit:2790
    each	@	jquery.js:2
    each	@	jquery.js:2
    $.fn.init_wysiwyg	@	post.php?post=3249&action=edit:2761
    (anonymous)	@	post.php?post=3249&action=edit:2751
    i	@	jquery.js:2
    fireWith	@	jquery.js:2
    ready	@	jquery.js:2
    K	@	jquery.js:2

    All of these problems and errors disappear once the CFS plugin is deactivated.

    I hope you can use the information above to provide an update that will allow your plugin to work properly with WordPress 4.9.1

Viewing 4 replies - 1 through 4 (of 4 total)
  • I am having the same issue. If I deactivate the plugin it’s fine but if the plugin is active the error causes buttons like adding feature image, setting post status or post release date to fail. It essentially makes it impossible to edit a post. Any insights into a fix would be greatly appreciated.

    JS error:

    post.php?post=1111&action=edit:1308

    Uncaught TypeError: Cannot read property ‘indexOf’ of undefined
    at HTMLDivElement.<anonymous> (post.php?post=1111&action=edit:1308)
    at Function.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)
    at a.fn.init.each (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)
    at a.fn.init.$.fn.init_wysiwyg (post.php?post=1111&action=edit:1279)
    at HTMLDocument.<anonymous> (post.php?post=1111&action=edit:1269)
    at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)
    at Function.ready (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)
    at HTMLDocument.K (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)

    Plugin Author Matt Gibbs

    (@mgibbs189)

    Thanks for reporting. This has been fixed in CFS 2.5.12.

    That fixed the error which is great thanks but you can’t toggle to code anymore and if you try to add an image to a wysiwyg field it jumps to the top and adds it to the post content.

    Jessie

    (@jcelestial047)

    Hi I’m having issue right now.

    no link formats in wysiwyg, and no code edit.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘CFS Plugin conflict with WP 4.9.1?’ is closed to new replies.