Support » Plugin: cformsII » cformsII v11 php v5.6 – external SMTP configuration

  • Resolved willcvc

    (@willcvc)


    Hi there,

    Greetings from South Africa!

    I’ve inherited a *very old* wordpress installation that was customised in such a way that it cannot be updated. Our current hosting provider is removing php 5.6 from its shared hosting shortly and as such we are forced to move to a new host that still supports it.

    Our DNS records have SPF+DKIM configured, so we would like to route our email through the old mail server.

    So, here is my problem – when submitting a form with an external mail server configured – despite having specified port 587 for the SMTP server, after submitting a form I receive this error;

    Warning: fsockopen(): unable to connect to smtp.[mydomain].com:25 (Connection timed out) in /my/hosting/path/public_html/wp-content/plugins/cforms2/phpmailer/class.smtp.php on line 122

    fsockopen() reports that it is attempting to connect to port 25 which is timing out, as expected (my mail provider does not accept connections on port 25).

    I appreciate that I am working with very outdated code here, but any assistance will be greatly appreciated!

    Versions:
    wordpress 3.0.5
    php 5.6
    cformsII 11.0

    Thanks in advance,
    Will

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author bgermann

    (@bgermann)

    This is actually a bug in the old cformsII. I intentionally removed the custom mail settings in the first version that I published.

    cformsII 11 ignores the port settings if SSL/TLS is not active. To work around the issue just use smtp.mydomain.com:587 as a hostname.

    Thank you very much!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.