Support » Plugin: cformsII » cformsII not sending emails, One Moment Please

  • Resolved geoswanko

    (@geoswanko)


    I’ve used this plugin for years on this site and it just stopped working recently. I’ve tried different emails and had others try it as well. It always stalls with “One moment please…” but no email is sent to admin or person sending the form.

    I checked the error log and it looks like the following sequence is repeated every one to two seconds:
    Stack trace:
    #0 /public_html/wp-content/plugins/cforms/lib_validate.php(104): cforms_is_email(‘1’)
    #1 /public_html/wp-content/plugins/cforms/lib_nonajax.php(13): require_once(‘/home1/user…’)
    #2 /public_html/wp-content/plugins/cforms/cforms.php(216): require_once(‘/home1/user…’)
    #3 /public_html/wp-content/plugins/cforms/cforms.php(1124): cforms(”, 4)
    #4 /public_html/wp-includes/class-wp-hook.php(286): cforms_insert(‘<h2 style=”text…’)
    #5 /public_html/wp-includes/plugin.php(203): WP_Hook->apply_filters(‘<h2 style=”text…’, Array)
    #6 /public_html/wp-includes/formatting.php(3313): apply_filters(‘the_content’, ‘<h2 style=”text…’)
    #7 /public_html/wp-includes/class-wp-hook.php(288): wp_trim_excerpt(‘<h2 style=”text…’)
    #8 /public_html/wp- in /public_html/wp-content/plugins/cforms/lib_validate.php on line 302
    [24-Jan-2019 10:08:36 UTC] PHP Fatal error: Uncaught Error: Call to undefined function eregi() in /public_html/wp-content/plugins/cforms/lib_validate.php:302

    I tried with the Ajax box unchecked, but then the whole webpage goes white and I still didn’t receive either email. I’ve tried the Check Email plugin and it worked. So I’m not really sure what’s going on. We’re using PHP 7.0 currently since that’s the highest our host has currently.

    Thanks for any assistance!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author bgermann

    (@bgermann)

    You are using a really old version that is incompatible with PHP 7.0 and has many security vulnerabilities. Please update to current cformsII version 14.14.

    Awesome! Just added the new one after deactivating the old one and added all the new codes and tested. Works well!

    Thanks so much!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘cformsII not sending emails, One Moment Please’ is closed to new replies.