Support » Plugin: Contact Form DB » CFDB with Google Spreadsheet = error 500

Viewing 15 replies - 1 through 15 (of 24 total)
  • update that I hope you find helpfull on bug-hunting.
    I tried with version 2.5, I get the exact same error.
    Wordpress Version 2.5.1
    Wordpress Contact Form 7 (in the array says “_wpcd_version 3.3.1”)

    It works (latest version) with Excel External Query (the thing that you download a file, put credentials and fills excel with data) with the same credentials giving “no permission” error (500) when trying to fetch from google spreadsheet.

    Exact same thing here. “error: Request failed for http://g*.org/wp-login.php?redirect_to=wp-admin/admin-ajax.php%3Faction%3Dcfdb-export%26form%3DAdoption%2BApplication returned code 500. Server response: <!DOCTYPE html>… etc etc etc…<p>You do not have sufficient permissions to access this data.</p></body> </html> (line 66, file “Code”)

    We have had errors on and off for years since linking the CF7 database to Goggle Spreadsheet Live. I think it’s something on the Google side, not the CF7 plugin. It eventually seems to resolve itself, though we suspect is has, on occasion, been something to do with the Google spreadsheet size limit. We sometimes clear out our dB, or spreadsheet, or both, which gets the thing running again. Just did that, but as of right now, we’re still getting the error, so no idea what’s up with it this time.

    after your note i renamed the form and base to be something simple (“bemember”) (to rule out some naming conversion problem, or something alike), but the error its still the same. I think the login works properly, because changing the credentials you get different errors indicating that login failed. I also cleared the database, having only a testing entry didnt change anything.

    I reinstalled this plugin on wordpress site, deleting assosiate files, but still same error. What is frustrating is that using the link in the error in the firefox address bar downloads the correct csv file.

    Plugin Author Michael Simpson

    (@msimpson)

    I did a quick test myself and I am also see the 500 error. I don’t know what is going on yet. I hope to have time to debug it this week.

    thank you michael, we look forward!

    Any news about this error? I have many google spreadsheet using this feature and now I’m down!!

    Thanks Michael.

    Plugin Author Michael Simpson

    (@msimpson)

    I have looked at it, but I haven’t worked out the problem yet. When I go through the steps manually in my browser it works, but via the Google API it is not getting past the WP login.

    A quick patch that worked for me.

    1) contact-form-7-to-database-extension/ExportToCsvUtf8.php: Added new If and commented old if.

    if($_REQUEST[“secret”] != “redacted”){
    $this->assertSecurityErrorMessage();
    return;
    }
    /*
    // Security Check
    if (!$this->isAuthorized()) {
    $this->assertSecurityErrorMessage();
    return;
    }
    */

    2) In Code.gs (script editor) added secret param.

    url += ‘%26’+encodeURI(“secret=redacted”);
    return UrlFetchApp.fetch(

    Hope it help as a temporary alternate,till actual fix is there.

    Hi Azghanvi. I tried this but, am still getting an error message that reads:

    “error: Request failed for http://mydomain.com/wp-login.php?redirect_to=wp-admin/admin-ajax.php%3Faction%3Dcfdb-export%26form%3DKeywords returned code 500. Server response:
    You do not have sufficient permissions to access this data.
    (line 66, file “Code”)”

    Also, in your #2 in the Code.gs I think there was a missing } bracket inbetween the lines and should be:

    url += ‘%26’+encodeURI(“secret=redacted”);
    }
    return UrlFetchApp.fetch(

    Also, my code in #2 started like this (which includes the search element):

    url += ‘%26search%3D’ + encodeURI(search);
    }
    return UrlFetchApp.fetch(

    So, I effectively replaced the first url line with yours.

    If you can lend any help that would be great. Bottom line is I’m still getting the above error message.

    Thanks!

    Ok, got this working. My issue was that I erased the “optional search” words but, left the parentheses. In any case I simply copies and pasted this from the code I put in with the script editor and everything instantly populated.

    =CF7ToDBData(“http://domain.com”, “formName”, “optional search”, “WPadminLogin”, “WPadminPassword”)

    Thanks much.

    workaround worked for me too. just a note, you can (and you should) replace words “secret” and “redacted” with something random, long and very difficult to guess, as a minimal security measure. As i far i can understand this overruns original security check with a “variable equals word” check. Use at your own risk.

    thanks for posting workaround.

    Hi
    is there a fix for that?
    i am getting an error (500) on connecting to google docs (it worked before…)
    thanks
    mili

    We are getting the following response.

    returned code 500. Server response: <!DOCTYPE html> <!-- Ticket #11289, IE bug fix: always pad the error page with enough characters such that it is greater than 512 bytes, even after gzip compression abcdefghijklmnopqrstuvwxyz1234567890aabbccddeeffgghhiijjkkllmmnnooppqqrrssttuuvvwwxxyyzz11223344556677889900abacbcbdcdcededfefegfgfhghgihihjijikjkjlklkmlmlnmnmononpopoqpqprqrqsrsrtstsubcbcdcdedefefgfabcadefbghicjkldmnoepqrfstugvwxhyz1i234j567k890laabmbccnddeoeffpgghqhiirjjksklltmmnunoovppqwqrrxsstytuuzvvw0wxx1yyz2z113223434455666777889890091abc2def3ghi4jkl5mno6pqr7stu8vwx9yz11aab2bcc3dd4ee5ff6gg7hh8ii9j0jk1kl2lmm3nnoo4p5pq6qrr7ss8tt9uuvv0wwx1x2yyzz13aba4cbcb5dcdc6dedfef8egf9gfh0ghg1ihi2hji3jik4jkj5lkl6kml7mln8mnm9ono --> <html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> <head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> <title>WordPress &rsaquo; Error</title> <style type="text/css"> ....</style> </head> <body id="error-page"> <p>You do not have sufficient permissions to access this data.</p></body> </html> (line 94, file "Code")

    The export to Excel Internet Query is working fine.

    Did something change in WordPress do you think? Or did the Google Spreadsheet functions change where its not posting correctly.

    I can do a curl from the command line and login fine with the same URLs the plugin gave me.

    @michael Simpson – Any update/fix to your plugin that solves the Exporting to Google Spreadsheet Live Data issue?

    I followed all your instructions but still got this error:

    error: Address unavailable: http://www.domain.com/wp-login.php?redirect_to=wp-admin/admin-ajax.php%3Faction%3Dcfdb-export%26form%3DContact%Form (line 66, file "Code")

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘CFDB with Google Spreadsheet = error 500’ is closed to new replies.