Support » Plugin: Contact Form 7 » CF7 spinning wheel not stopping

  • Resolved saditya

    (@saditya)


    Hi Everyone,

    I have my client site it i have installed contact form 7 i was working from long time but since 1 month i am facing this problem contact form is submitting and i am getting mail also but that spinning wheel beside submit button is continuously spinning after submission also.

    Please help !

    Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    saditya

    (@saditya)

    I did these all sir but it does not help.

    Now it is solved. I did following:

    Open file:
    /wp-content/plugins/contact-form-7/wp-contact-form-7.php

    Change this:
    define( ‘WPCF7_LOAD_JS’, true);

    To this:
    define( ‘WPCF7_LOAD_JS’, false );

    Thank you

    • This reply was modified 3 years ago by saditya.
    kairig

    (@kairig)

    I am having the same problem. Though when I tried the solution mentioned above, I got this warning popping up after I submit a form. It stopped the spinny arrow, but this displays across the top of the page.

    Warning: Creating default object from empty value in /home1/raleigh/public_html/vimproducts.com/wp-content/plugins/root-relative-urls/sb_root_relative_urls.php on line 97

    The FAQ you link to says that this is due to a plug in conflict. But I have 4 contact forms on my site and the spinning wheel only affects one of them.
    Here’s one that works just fine http://nutritionovereasy.com/thriving/

    And here’s one that worked fine for years but suddenly doesn’t: http://nutritionovereasy.com/contact

    Ideas?

    I had the same problem and resolved it by disabling the following plugin:

    “Contact Form 7 Email Validation”

    Hope that helps!

    @saditya Thank you for posting your solution. It worked for me.

    Have the same problem. I tried Saditya’s solution.
    It definitely fixed the problem, but now there is an error message which can be seen just below the header.

    Warning: fopen(https://…@us13.api.mailchimp.com/3.0/lists/7d802f8ddd): failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden in /home/refugere/public_html/wp-content/plugins/contact-form-7-mailchimp-extension/lib/functions.php on line 329

    Warning: stream_get_contents() expects parameter 1 to be resource, boolean given in /home/refugere/public_html/wp-content/plugins/contact-form-7-mailchimp-extension/lib/functions.php on line 329

    I have the same issue, have tried many things, but have not found the solution yet.

    Well, the developer says it’s a plugins conflict that can be solved removing other plugins…. this doesn’t sound to me like a professional answer at all!

    Googling you can find many people saying they’re facing the same issue in many different environment configuration, so, it seems the developer refuses to admit that the badly developed plugin is CF7.

    It’s hard to say this, ’cause I really loved CF7, but as most of the things, also this love couldn’t last forever.

    Bye Bye CF7, I’m forced to move to another plugin!

    Even if it shoud do the same thing “define( ‘WPCF7_LOAD_JS’, false );” has not worked for me but, adding:
    add_filter( ‘wpcf7_load_js’, ‘__return_false’ );
    in functions.php did the trick!

    In my environment the JS conflict was with WPML, sending ok from default language but hanging on localized pages.

    Good luck!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘CF7 spinning wheel not stopping’ is closed to new replies.