Support » Plugin: Contact Form 7 » CF7 Server/Ajax Error (arrow just spins)

  • Resolved ruffneck119


    This is the site: (please do not fill out the form).

    When you click on the submit button the arrows just spin. The message will be sent if everything is filled out correctly but nothing happens with the form. Same thing with errors, it just spins even though it should be showing the errors.

    The odd thing is if I put the same EXACT WordPress installation (SAME theme, same plugins, db, everything) on another server the form works just fine. I also get no errors in the console but I do get this odd things showing up in firebug: (which I think is called from controller.php on line 14: if ( ‘GET’ != $_SERVER[‘REQUEST_METHOD’] || ! isset( $_GET[‘_wpcf7_is_ajax_call’] ) )

    I had the same issue with another installation on the same cpanel and when I moved the site everything worked fine. So I am not sure what could be causing this issue.

    PS: It’s on a host gator VPS and the cpanels on the same server work fine and I already tried the deactivate all plugins and use another theme thing. Newest version of CF7 and already tried a fresh install…

Viewing 7 replies - 1 through 7 (of 7 total)
  • So I figured it’s not the server, but I am still having the same issue. I have no clue whats wrong. I disabled all other plugins and a few other scripts now when you do not enter the form right it takes you to another page and the css is messed up for the warning messages.

    Plugin Author Takayuki Miyoshi


    Theme issue. Try switching theme to the default one.

    Also see this post:
    Why isn’t My AJAX Contact Form Working Correctly?

    I have the wp head and wp footer. No script conflicts in firebug. Validation was fine.

    This is the only error I get on submission:

    I’m having the same problem except it does send the mail to me, But the client does not know it sent. When I click on inspect Elements I get this:
    if (! $.isPlainObject(data) || $.isEmptyObject(data))

    Then this Error:
    Uncaught type error: object function (selector, Context){ “the JQuery object is Actually just the init constructor ‘enhanced’ Return new JQuery.fn.init (selector,content);}has no method is plain object’

    I have two other pages running fine on contact 7 and I set up all three the same way.

    I just ran into the same issue troubleshooting this problem for a client’s website. The form sends, but the results never display, the spinner just continues to spin.

    The site uses a custom-designed header that loads a local copy of jQuery.js (instead of the one installed with WordPress). So 2 copies of jquery loading causing the conflict.

    I commented out the line of code that loads the jquery.js in the header.php of the custom theme and everything works again.

    Hope this helps someone else resolve this.

    The way jQuery is called in my theme is like this (in functions.php):

    function load_jquery() {
    // only use this method is we’re not in wp-admin
    if (!is_admin())
    wp_deregister_script( ‘jquery’ );
    wp_register_script(‘jquery’, ”, FALSE, ‘1.8.3’);
    add_action(‘template_redirect’, ‘load_jquery’);

    And then it is loaded in my header:
    <script type=’text/javascript’ src='<?php bloginfo(‘template_directory’); ?>/js/jquery-1.8.3.js’></script>

    Figured out the issue. I took out the code from the plugin script.js file:

    data = data.substring(data.indexOf(“{“));

    data = $.parseJSON(data);

    Because this kept being called over and over again:

    data: { ‘_wpcf7_is_ajax_call’: 1 },
    dataType: ‘json’,
    success: function(data) {

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘CF7 Server/Ajax Error (arrow just spins)’ is closed to new replies.