Support » Plugin: Contact Form 7 » CF7 & reCaptcha v3: There was an error trying to send your message.

  • Resolved Tobys

    (@tobys)


    So, like everyone else I am getting this error message with the introduction of reCaptcha v3 in Contact Form 7:

    “There was an error trying to send your message. Please try again later.”

    I have tried the suggested solutions here, but none of them work.

    Also, I have read many reports that the spam has increased since bots can disable JavaScript and circumvent some of the spam protection.

    Furthermore, the reCaptcha image AND code is now on every page.

    I am specifically NOT loading Contact Form 7 code on any other page than my contact form page. I know that reCaptcha analysis user behavior throughout the whole site, but I do not under any circumstance want to add additional JavaScript to all other pages just to have a simple contact form.

    This will affect both the performance of the site, but also the sites privacy policy since users are now being monitored by reCaptcha (Google).

    Unfortunately, this means goodbye to Contact Form 7 for all my sites and client sites – at least until we can get reCaptcha 2 back as an option.

Viewing 12 replies - 16 through 27 (of 27 total)
  • Having the same issue. Walked through the steps to add reCAPTCHA v3 and put in the Site Key and Secret Key. Once it’s added I can no longer send e-mails through the contact form.

    Contact Form 7 (5.1.1) and reCAPTCHA v3: When testing a form, at the first attempt to send it, we have an error message with orange border (There was an error trying to send your message. Please try again later.) If I retry to send the form, it seems working and we have a message with green border (Thank you for your message. It has been send.) Can you explain this???

    Solution,

    for now is to install this addon, and use V2 reCAPTCHA.

    https://wordpress.org/plugins/wpcf7-recaptcha/

    I hope CF7 will fix this problem in next update!

    Best Regards,

    • This reply was modified 2 months, 1 week ago by  mrjukic.

    We are still using CF7 with reCAPTCHA V3. We only add to our form a text telling to the user: please, send your form again if you have an error.

    funsail

    (@funsail)

    Far out, this is rubbish. CF7 has always been a high and mighty plugin, with poor developer options forced on users. But why would you make a reCAPTCHA V3 forced feature that doesn’t and never has worked?

    shree

    (@snehashri)

    I’m having the same problem, if i add the integration keys to the site, then it throws the error “There was an error trying to send your message. Please try again later.” please suggest something how to get rid of that?

    Having the same issue on multiple sites using multiple themes on multiple hosting platforms (we manage over 400 sites) This is for sure a plugin issue and need to be resolved asap as right now all forms cannot receive email.

    Please advise???

    Hi,

    Struggled with this for a while. My issue was using wp cerber not configured correctly to allow contact form 7. If this helps anyone a few headaches you have to go to the cerber dashboard > hardening > then in allow these namespaces > add contact-form-7

    Hope this helps anyone.

    Cheers,

    P

    altima-interactive

    (@altima-interactive)

    Still a problem. Had to disable recaptcha and get spam 🙁

    I believe what you need is an additional plugin called Contact Form 7 – reCaptcha v2.

    Do NOT delete your original Contact Form 7 or any of your existing forms and Site Key/Secret Key.

    Just install the plugin mentioned above, and after activating, you will see an additional setting called reCaptcha Version. Go there and change Default Usage to reCaptcha Version 2, and click on Submit.

    Your form should now work as normal. Took me quite a bit of testing and trial and error to get this working eventually. Hope it helps!

    • This reply was modified 1 month, 1 week ago by  devonbuy.

    Make sure you have the exact full domain name in your Google reCaptcha v3 API settings under “Domains”, as in “www.example.com” if you use the “www” in your site URL, not just “example.com”. You can list both in there, if you want, just to cover all the bases.

    I had similar symptoms due to leaving out the “www.” in the google API settings. I also used some CSS to hide the recaptcha logo on pages without CP7 forms and javascript to un-hide it on pages with CP7 forms. If you are comfortable with custom child-themes, (or *gasp* modifiying an existing theme driectly) you can add a couple CSS rules and a short script to control when the reCaptcha icon gets displayed. The code I used is based on what NightL posted here: https://wordpress.org/support/topic/annoying-floating-recaptcha-box/

    CSS & jquery – makes the badge only visible when a CF7 form is clicked or written into.
    It still loads the script on each page in the background – which is necessary.

    .grecaptcha-badge {
    visibility: hidden;
    opacity: 0;
    transition: linear opacity 1s;
    }
    
    .grecaptcha-badge.showgr {
    visibility: visible;
    opacity: 1;
    transition: linear opacity 1s;
    }

    I used NightL’s CSS from above and WP’s internal JQuery to run the script by adding a slightly modified version of NightL’s script in my themes …_enqueue_scripts() function
    wp_enqueue_script("jquery");
    And also a line to enqueue the script file below. The line to enqueue your script will most likely look different from how I did it depending on how you work it into your theme.

    My modification of the script was just to wrap it in the JQuery closure as follows:

    (function($) {
        $(document).ready(function () {
            $( "input[type=text],input[type=email], textarea " ).focus(function() {
                $('.grecaptcha-badge').addClass('showgr');
            });
        });
    })( jQuery );
    

    [edit] Oh, and I forgot to mention. It sends the email without errors now, but I haven’t had it set up this way long enough to see the difference in spam, yet.

    • This reply was modified 4 weeks, 1 day ago by  coldsnaptech. Reason: Fixed typos and forgot to say that this works :)
    • This reply was modified 4 weeks, 1 day ago by  coldsnaptech. Reason: more typos
    • This reply was modified 4 weeks, 1 day ago by  coldsnaptech. Reason: code indenting fix

    @coldsnaptech — thank you.

    Make sure you have the exact full domain name in your Google reCaptcha v3 API settings under “Domains”, as in “www.example.com” if you use the “www” in your site URL, not just “example.com”. You can list both in there, if you want, just to cover all the bases.

    That works for me.

Viewing 12 replies - 16 through 27 (of 27 total)
  • You must be logged in to reply to this topic.