Support » Plugin: Async JavaScript » CF7 ReCaptcha V3 issue

  • Hey Guys,

    I wonder if you could help share some light on my issue.

    I have tried using your plugin to help with javascript loading. And it has helped with some javascripts but not all. But, the issue I’m facing is with Contact Form 7 and the integrated ReCaptcha V3.

    I have tried all different kinds of combinations but I seem to get a console error, no matter what I try, when your plugin and active and enabled. The error I am getting is:

    ReferenceError: grecaptcha is not defined at https://amillerfinancial.co.uk/:808:2

    This breaks the ReCaptcha and stops forms from working correctly.

    I tried added contact form 7 as an excluded plugin, but this still didn’t fix it. I also excluded this line in the scripts box:

    https://www.gstatic.com/recaptcha/api2/v1559543665173/recaptcha__en.js

    Which also never helped.

    I’m not sure what is happening as the error relates to this line of code in the source:

    grecaptcha,
    	'site-key',
    	{"homepage":"homepage","contactform":"contactform"}

    But it only happens when your plugin is active and enabled. Can you help solve this or do you know what the issue is?

    Kind regards,

    Kevin

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘CF7 ReCaptcha V3 issue’ is closed to new replies.