Support » Plugin: Contact Form 7 » CF7 not adding "The field is required" for Required Select fields

  • Resolved Neil Murray

    (@buzztone)


    When I submit form at http://www.belvedere-samos.com/rsv-request/ the “The field is required” messages are not displaying for 2 Required Select fields.

    See http://www.screencast.com/t/OSfMpkDuUews

    Contact Form 7 is not adding the “The field is required” HTML for 2 Required Select fields as shown below:

    Field not working:
    <ol data-row-span="2">
    <li>
    <label for="your-persons">
    <span class="wpcf7-form-control-wrap your-persons">
    <select class="wpcf7-form-control wpcf7-select wpcf7-validates-as-required" aria-invalid="false" aria-
    required="true" name="your-persons">
    <option value="1">1</option>
    <option value="2">2</option>
    <option value="3">3</option>
    <option value="4">4</option>
    <option value="5">5</option>
    </select>
    </span>
    </li>
    <li>
    
    Missing:
    <span class="wpcf7-not-valid-tip" role="alert">The field is required.</span>
    
    Field above working:
    <ol class="singleline" data-row-span="2">
    <li data-field-span="1">
    <label for="your-arrivaldate">
    <span class="wpcf7-form-control-wrap your-arrivaldate">
    <input id="dp1469134485277" class="wpcf7-form-control wpcf7-date wpcf7-validates-as-required wpcf7-validates-as-
    date hasDatepicker wpcf7-not-valid" type="date" aria-invalid="true" aria-required="true" max="2018-12-31"
    min="2016-01-01" value="" name="your-arrivaldate">
    <span class="wpcf7-not-valid-tip" role="alert">The field is required.</span>
    </span>
    </li>
    <li data-field-span="1">
    </ol>

    Note: The form is also using Contact Form 7 Skins to style the form.

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘CF7 not adding "The field is required" for Required Select fields’ is closed to new replies.