Support » Plugin: Contact Form 7 » CF7 4.8 not sending. Rebuilding permalinks fixed it for us.

  • Resolved tom.andersen

    (@tomandersen)


    In reference to the top 4 or so posts about CF7 version 4.8 not sending

    Try rebuilding your permalinks: Go to your permalinks under settings and then turn it to none, press save then back to your current setting then press save again.

    Fixed this exact problem for us.

Viewing 6 replies - 1 through 6 (of 6 total)
  • kenman

    (@kenman)

    Hey Tom,
    When you say set it to “none” was that the plain option, or did you actually put “none” in custom structure? I tried setting it to plain, didn’t work and also tried rolling back to 4.7 – no luck 🙁

    linux4me2

    (@linux4me2)

    I tried this on a clean install of WP 4.8 with CF7 4.8 and with anonymous REST API blocked, but it didn’t solve the problem to rebuild the permalinks.

    @tomandersen – Make sure you aren’t logged in to WP when you test; if you are, CF7 4.8 sends fine even with anonymous REST API blocked.

    frenchomatic

    (@frenchomatic)

    Confirmed WordPress V4.8 and latest contact form 7 V4.8- blocking the Rest API either through htaccess or via a plugin like Ninja firewall means the form will not send and eventually runs to a time out. Allowing the REST API and json to be accessed is a major security issue. If your site gets attention you will be hacked – odds on. This really needs fixing quickly.

    frenchomatic

    (@frenchomatic)

    Downgraded to CF version 4.7 and all is well.

    Barbra Wolfe

    (@barbra-wolfe)

    @frenchomatic Thanks so much for posting this fix. Did you need to delete the new contact form 7.4.8 before you installed the 7.4.7? Or just deactivate the new one and activate the new one?

    justdave

    (@justdave)

    I had to delete the old one then install 4.7. It wouldn’t let me downgrade in place.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.