Support » Plugin: LifterLMS » Certificates issue

  • Resolved dantheman1981

    (@dantheman1981)


    Hi,

    I have created a course and certificate. When I complete the course, I get a notification about the certificate and it is also viewable in the ‘Notifications’ section of the Dashboard.

    My problem is that the certificate is not in the ‘My Certificates’ section.

    Thanks.

    ——————————————-

    Home Url: https://servoskills.com.au
    Site Url: https://servoskills.com.au
    Login Url: https://servoskills.com.au/wp-login.php
    Version: 5.1.1
    Debug Mode: No
    Debug Log: No
    Debug Display: Yes
    Locale: en_US
    Multisite: No
    Page For Posts: Not Set
    Page On Front: HOME (#12) [https://servoskills.com.au/]
    Permalink Structure: /%postname%/
    Show On Front: page
    Wp Cron: Yes

    Settings
    ——————————————-

    Version: 3.30.3
    Db Version: 3.30.3
    Course Catalog: COURSE LIBRARY (#422) [https://servoskills.com.au/course-library/]
    Membership Catalog: Membership Catalog (#359) [https://servoskills.com.au/memberships/]
    Student Dashboard: STUDENT DASHBOARD (#361) [https://servoskills.com.au/student-dashboard/]
    Checkout Page: Purchase (#360) [https://servoskills.com.au/purchase/]
    Course Catalog Per Page: 9
    Course Catalog Sorting: menu_order,ASC
    Membership Catalog Per Page: 9
    Membership Catalog Sorting: menu_order
    Site Membership: Not Set
    Courses Endpoint: my-courses
    Edit Endpoint: edit-account
    Lost Password Endpoint: lost-password
    Vouchers Endpoint: redeem-voucher
    Autogenerate Username: yes
    Password Strength Meter: no
    Minimum Password Strength: strong
    Terms Required: no
    Terms Page: Not Set
    Checkout Names: required
    Checkout Address: hidden
    Checkout Phone: hidden
    Checkout Email Confirmation: yes
    Open Registration: yes
    Registration Names: required
    Registration Address: hidden
    Registration Phone: hidden
    Registration Voucher: required
    Registration Email Confirmation: yes
    Account Names: required
    Account Address: optional
    Account Phone: optional
    Account Email Confirmation: yes
    Confirmation Endpoint: confirm-payment
    Force Ssl Checkout: no
    Country: AU
    Currency: AUD
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Decimals: 2
    Trim Zero Decimals: no
    Recurring Payments: yes
    Email From Address: admin@servoskills.com.au
    Email From Name: ServoSkills
    Email Footer Text:
    Email Header Image:
    Cert Bg Width: 800
    Cert Bg Height: 616
    Cert Legacy Compat: no

    Gateways
    ——————————————-

    Manual: Disabled
    Manual Logging:
    Manual Order: 1

    Server
    ——————————————-

    Mysql Version: 5.7.24
    Php Curl: Yes
    Php Default Timezone: UTC
    Php Fsockopen: Yes
    Php Max Input Vars: 1000
    Php Max Upload Size: 8 MB
    Php Memory Limit: 256M
    Php Post Max Size: 8M
    Php Soap: No
    Php Suhosin: No
    Php Time Limt: 30
    Php Version: 7.2.12
    Software: Apache
    Wp Memory Limit: 40M

    Browser
    ——————————————-

    HTTP USER AGENT: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36

    Theme
    ——————————————-

    Name: Astra
    Version: 1.8.2
    Themeuri: https://wpastra.com/
    Authoruri: https://wpastra.com/about/
    Template:
    Child Theme: No
    Llms Support: Yes

    Plugins
    ——————————————-

    Astra Pro: 1.8.1
    Astra Starter Sites – Elementor, Beaver Builder & Gutenberg Templates: 1.3.7
    Classic Editor: 1.4
    Contact Form 7: 5.1.1
    Elementor: 2.5.14
    Header, Footer & Blocks for Elementor: 1.1.2
    LifterLMS: 3.30.3
    Really Simple SSL: 3.1.5
    Ultimate Addons for Gutenberg: 1.13.1
    WPForms Lite: 1.5.2.3

    Integrations
    ——————————————-

    BbPress: No
    BuddyPress: No

    Template Overrides
    ——————————————-

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Natalie

    (@nrherron)

    Hi @dantheman1981,

    I’m sorry you’re having this issue!

    Could you tell me the settings you have for your certificate exactly, and which course the certificate should be triggering when you complete it.

    This can be found under Engagements. If you select the certificate you created an engagement for it should show you the Engagement Options, that is the information I’m asking for.

    I suspect that something maybe didn’t get saved properly when you created the engagement to trigger the certificate, so the notification is sending the you earned a certificate but it’s not assigning the certificate itself!

    Let me know what those settings are and we can continue to troubleshoot from there!

    Thanks and take care

    Hi Natalie,

    Below are the options I have selected. I can’t see how to send you a screen shot.

    It should be triggering the course ‘Food Safety Training’.

    Triggering Event
    This engagement will be triggered when a student completes the selected action
    –Student completes a course

    Select a Course
    –Food Safety Training

    Engagement Type
    Determines the type of engagement
    –Award a certificate

    Select an Engagement
    –Armed Robbery Safety Training Completion Certificate

    Engagement Delay
    Enter the number of days to wait before triggering this engagement. Enter 0 or leave blank to trigger immediately.
    — Left this blank

    Thanks for your help.

    Dan.

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @dantheman1981,

    This all seems right and if you’re getting the notification it should be displaying in the certificates area on the dashboard.

    Can you check the reporting section for your test student / user and see if the certificate can be found in the certificates reporting area? If it is that can confirm that the certificate was correctly generated which helps us a bit…

    I really don’t know why it wouldn’t be showing on the student dashboard under certificates.

    I’m wondering if there’s maybe some custom CSS that’s accidentally hiding it? Could you check your “Additional CSS” area in the customizer and see if there’s anything there?

    Hi Thomas,

    Haven’t been able to get to the bottom of this yet.

    I have checked the reporting section and the certificate is showing up there for the test user.

    Below is what I have as custom CSS, do you think this should cause an issue?

    /*
    LifterLMS Custom CSS
    */

    /* Meta Removal */
    .llms-loop-item-footer, .llms-meta-info {
    display: none
    }

    /* Course Title Center */
    .llms-loop-item-content .llms-loop-title {
    font-size: 18px;
    font-weight: 600;
    margin-top: 20px;
    text-align: center;
    }

    /* Dashboard Colors */
    .llms-loop-item-content {
    background: #F9F9FB;
    }

    .llms-loop-item-content:hover {
    background: #F9F9FB;
    }

    /* Dashboard Title Hide */
    h3.llms-sd-section-title {
    display:none;
    }

    /* Sylabus Lesson Background color */
    .single-lesson.ast-separate-container .llms-lesson-preview .llms-lesson-link, .single-course article .llms-syllabus-wrapper .llms-lesson-preview .llms-lesson-link {
    background-color: #F9F9FB!important;
    }

    .single-lesson.ast-separate-container .llms-lesson-preview .llms-lesson-link:hover, .single-course article .llms-syllabus-wrapper .llms-lesson-preview .llms-lesson-link:hover {
    background: #FFF!important;
    }

    /* Clean Up Members Dashboard */
    .llms-access-plan-featured, .llms-my-certificates, .llms-my-achievements {
    display: none;
    }

    Thanks for your help,

    Dan.

    Hi Thomas,

    Just following up on this, any suggestions?

    Thanks,

    Dan.

    Hi Thomas,

    Wondering if you are seeing my messages?

    Thanks,

    Dan.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.