Support » Plugin: CSV Importer & Exporter » Certain custom post type not visible

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author smackcoders

    (@smackcoders)

    What custom post plugin you use? It should be enabled under both modules and 3rd party plugins. Hope this is the issue.

    I havn’t used any plugin for my custom post types.

    Here is the code for my custom post type in question

    add_action( 'init', 'register_cpt_product' );
        function register_cpt_product() {
        $labels = array(
        'name' => _x( 'Products', 'product' ),
        'singular_name' => _x( 'Product', 'product' ),
        'add_new' => _x( 'Add New Products', 'product' ),
        'add_new_item' => _x( 'Add New Product', 'product' ),
        'edit_item' => _x( 'Edit Product', 'product' ),
        'new_item' => _x( 'New Product', 'product' ),
        'view_item' => _x( 'View Product', 'product' ),
        'search_items' => _x( 'Search Products', 'product' ),
        'not_found' => _x( 'No products found', 'product' ),
        'not_found_in_trash' => _x( 'No products found in Trash', 'product' ),
        'parent_item_colon' => _x( 'Parent Product:', 'product' ),
        'menu_name' => _x( 'Products', 'product' ),
        );
        $args = array(
        'labels' => $labels,
        'hierarchical' => true,
        'description' => 'Add new view and edit Products for your website',
        'supports' => array( 'title', 'editor', 'excerpt', 'author', 'thumbnail', 'revisions' ),
        'taxonomies' => array( 'Product Categories' ),
        'public' => true,
        'show_ui' => true,
        'show_in_menu' => true,
        'menu_position' => 5,
        'show_in_nav_menus' => true,
        'publicly_queryable' => true,
        'exclude_from_search' => false,
        'has_archive' => true,
        'query_var' => true,
        'can_export' => true,
        'rewrite' => true,
        'capability_type' => 'post'
        );
        register_post_type( 'product', $args );
        }
    Plugin Author smackcoders

    (@smackcoders)

    We have evaluated the issue. Custom post types created with register_post_type is not being supported in present version on csv importer. But will add this in near future version.

    I have the same issue, my CPT is also called “product”. But I have another one created via Bones Theme custom post type template via register_post_type() and it works. I have another one that shows up in the list (called “finish”), and even the default “custom_type “from Bones shows up.

    I think it has something to do with the custom post type cannot be registered with the name “product”. Is that a special name reserved for other things?

    Same issue as above. It does appear like ‘product’ as a post type is reserved for something else.

    Hi guys, sorry I haven’t responded. But yes i solved the issue by renaming product to blogname_product and it works perfectly. I’d day this is how to resolve the issue

    I upgraded to the new version, and am having problems. I uploaded 5 draft posts to a custom post type. It shows a (5) next to drafts, indicating there are 5 posts there (like I uploaded) but there are no actual posts showing up below on the edit screen. Can you please let me know how to resolve? Thank you.

    I also need to know how to upload so this doesn’t happen again. The old plugin worked beautifully. Thanks!

    Plugin Author smackcoders

    (@smackcoders)

    Odd issue, try delete and reinstall the plugin again. Hope this may solve the issue. If not let me know. Also kindly start a new thread it is hard to track issues here.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Certain custom post type not visible’ is closed to new replies.