Support » Plugin: Easy Table of Contents » ‘ez-toc-container’ in a post causes TOC disappear

  • Resolved powercliff

    (@powercliff)


    Hi,

    Well…The situation is very special.
    I am writing an article, which describes some tips and codes to improve this plugin (https://wordpress.org/support/plugin/easy-table-of-contents).
    and I insert a code block in the article. Then I find that the TOC below the article disappeared.

    It took me a long time to find the way to reproduce it:
    I created a new wordpress environment to test this without any other plugins and themes.
    Then I created a new post which contains text ‘ez-toc-container’ in the article,
    and then the TOC below the title disappeared like magic.

    It is very clear that I can solve my problem by removing ‘ez-toc-container’ in my article, but I do not think it is a perfect solution. I think it is a bug related problem.

    Can you tell me the reason behind this? Thank you !

    • This topic was modified 4 months, 2 weeks ago by powercliff.
    • This topic was modified 4 months, 2 weeks ago by powercliff.
    • This topic was modified 4 months, 2 weeks ago by powercliff.
    • This topic was modified 4 months, 2 weeks ago by powercliff.
    • This topic was modified 4 months, 2 weeks ago by powercliff.
    • This topic was modified 4 months, 2 weeks ago by powercliff.
    • This topic was modified 4 months, 2 weeks ago by powercliff.
Viewing 1 replies (of 1 total)
  • Plugin Author Steven

    (@shazahm1hotmailcom)

    RE: ez-toc-container

    In order to prevent multiple instances of the TOC, ezTOC checks for its container and if found, it will not embed it a second time. It’s not a bug.

    I hope this helps!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.