Support » Plugin: Wordfence Security - Firewall & Malware Scan » Central : Unable to communicate with Wordfence plugin

  • Resolved pierreripka

    (@pierreripka)


    Hello,

    I work in a web agency and currently have 111 sites connected to Wordfence Central.

    Only one site cannot be connected, yet I think I did everything right:

    – Clear all Wordfence Central connection data (no change)
    – Admin account with the same email used to register to Wordfence Central
    – Don’t use Cloudflare, Incapsula, Sucuri or WP Spamshield
    – REST API not disabled
    – Latest version of Wordfence (7.4.11)
    – Everything is OK in Diagnostics > Connectivity

    When I try to add the site to Wordfence Central I get the following message:
    “Unable to communicate with Wordfence plugin. Please verify Wordfence is installed and activated on this site.”

    The site was able to connect to Wordfence Central a few weeks ago.
    I don’t know why it can’t connect anymore.

    Can you help me please?

    Regards,
    Pierre

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support wfpeter

    (@wfpeter)

    Hi @pierreripka, thanks for reaching out on this.

    It does appear that you have tried all of the steps we will often suggest as a first-response and in: https://www.wordfence.com/help/central/connect/#troubleshooting-connection-issues

    I think the next step would be to send us a diagnostic report to wftest @ wordfence . com. You can find the link to do so at the top of the Wordfence Tools > Diagnostics page. Then click on “Send Report by Email”. Please add your forum username where indicated and respond here after you have sent it.

    Note: For the fastest response time, please make sure and add any information or questions directly to this topic and not the email address above unless asked.

    Thanks,

    Peter.

    Thread Starter pierreripka

    (@pierreripka)

    Hi Peter,

    Thanks for your reply.
    I just sent the report as requested.

    Regards,
    Pierre

    Plugin Support wfpeter

    (@wfpeter)

    Hi @pierreripka, thanks for sending that over to us.

    Have you recently hidden the login page, as the default WordPress URL 404s for me? I think that this may be the issue with this site connecting to Wordfence Central as we check back to the site during the connection phase.

    Here’s a video on why we think you don’t need to hide the login page:

    https://www.wordfence.com/blog/2017/10/should-you-hide-wordpress-login-page/

    Let me know how you get on.

    Peter.

    Thread Starter pierreripka

    (@pierreripka)

    Hi Peter,

    Thanks for your feedback.

    Indeed, the login page is hidden with WPS Hide Login.
    However this is not what is blocking the connection, I tried to deactivate the plugin and it does not change anything.
    On the hundred other sites that I manage, this plugin is also installed and the connection is established without any issue.

    I have seen this video before and share your point of view about that.
    However, we were previously using iThemes Security which already hid the login pages and we wanted to avoid such an important change on every site switching to Wordfence, which would have been a bit complicated to explain to our clients in addition to taking a lot of time.

    In any case, that’s not the issue here, so I reactivated the plugin.
    Thanks again for your help, hope we will find out what is wrong.

    Regards,
    Pierre

    Plugin Support wfpeter

    (@wfpeter)

    Hi @pierreripka, thanks for letting us know. We have had some further discussions internally and managed to get you some more information.

    Your REST API endpoint is returning a UTF-8 BOM which is breaking the JSON response. We actually have a fix for this at Wordfence Central’s end that should be going into production by Monday. The cause is likely a PHP file starting with the following bytes, which the fix will now allow for: \xEF\xBB\xBF

    Hopefully this should address the problem for you going forward.

    Thanks again,

    Peter.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Central : Unable to communicate with Wordfence plugin’ is closed to new replies.