Support » Localhost Installs » CentOS 5.5 install – what version of WP?

  • I’d like to install WordPress on my Centos 5.5 server. I’ve been told to install the latest version of WordPress for security, but I’m only running php 5.1.6 (WordPress 3.4.1 needs Php 5.2.4.)

    My php is up to date with the available yum installs for CentOS. I’m hesitant to try to update further and possibly break other older software installs that currently use the php 5.1.6 install.

    I see on the requirements page that:

    The requirements have changed as of WordPress 3.2. The minimum requirements for WordPress 3.1 are PHP 4.3 and MySQL 4.1.2.

    Is 3.1 a stable/secure version of WP, or should I really find a way to upgrade my php and install 3.4.1?

    Thank you,

    Vira R.

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi

    (@esmi)

    Forum Moderator

    Do not install an older version of WordPress. Upgrade your PHP instead.

    If you are looking into self hosting on your own self-built server, I recommend starting with Ubuntu. There are so many guides out there, all Debian/Ubuntu based. Everything you could want for a decent WordPress hosting environment is available ‘out of the box’ via apt-get.

    That includes: MySQL, PHP, Nginx, APC, FPM, Exim, Apache, memcache

    Once you have that under your belt, move back to CentOS if you really want/have to?

    For what it’s worth I’m running a CentOS server and had no problems resulting from upgrading PHP to accommodate the latest versions of WP.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘CentOS 5.5 install – what version of WP?’ is closed to new replies.