Support » Plugin: Fast Velocity Minify » CDN-option

  • Resolved hkim00

    (@hkim00)


    I’m experiencing a strange error when I use “CDN Options” to use my CDN domain. When I define the CDN domain: https://psnuab.b-cdn.net or just psnuab.b-cdn.net, I get following error in GTMetrix:

    Headers
    https://psykolog.nu/psnuab.b-cdn.net
    Response Version
    HTTP/2.0
    Response Headers
    link	
    <https://psykolog.nu/wp-json/>; rel="https://api.w.org/"
    x-cache-2	
    BYPASS
    x-powered-by	
    centminmod
    cache-control	
    no-cache, must-revalidate, max-age=0
    status	
    404
    date	
    Wed, 20 Mar 2019 06:20:38 GMT
    vary	
    Accept-Encoding
    content-encoding	
    gzip
    content-type	
    text/html; charset=UTF-8
    x-xss-protection	
    1; mode=block
    x-content-type-options	
    nosniff
    server	
    nginx centminmod
    x-cache	
    MISS
    expires	
    Wed, 11 Jan 1984 05:00:00 GMT
    Request Version
    HTTP/2.0
    Request Headers
    user-agent	
    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36
    accept	
    */*
    :method	
    GET
    accept-language	
    en-US,en;q=0.9
    accept-encoding	
    gzip, deflate, br
    :authority	
    psykolog.nu
    :scheme	
    https
    :path	
    /psnuab.b-cdn.net
    referer	
    https://psykolog.nu/

    The header https://psykolog.nu/psnuab.b-cdn.net is obviously wrong.How should I use the CDN option in FVM? If I leave the CDN option empty, no errors are displayed in GTMetrix.

    • This topic was modified 5 months, 4 weeks ago by  hkim00.
    • This topic was modified 5 months, 4 weeks ago by  Jan Dembowski.
Viewing 2 replies - 1 through 2 (of 2 total)
  • It doesn’t seem like FVM is “…rewrite the static assets urls inside FVM merged files to your cdn domain. Usage: cdn.example.com” on my configuration. All it does it to add my cdn domain to my website URL.

    What can be causing this?

    Plugin Author Raul Peixoto

    (@alignak)

    @hkim00 I tested this today and I do not see that behaviour with the default 2019 theme.

    Do you use some other plugin to deal with the CDN rewriting?
    Or do you use some other plugin to do speed optimization, which may be trying to preload stuff in the header?

    That looks like some other plugin or the theme, is reading your html and finding the cdn domain, however it doesn’t detect it properly and will then add it to the preload headers.

    I don’t see any https://psykolog.nu/psnuab.b-cdn.net reference on your html site, so it could also be a cdn/server setting.

    You could rename each plugin one by one via sftp (do not access the wp-admin plugins page) and see which one it’s causing the issue. Renaming it back, will restore the default behaviour, provided you haven’t access the plugins page (else it will detect the renaming and disable the plugin).

    Make a backup first.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.