Support » Plugin: Holler Box - Lightweight popup plugin » CDN images not showing

  • ResolvedModerator Bet Hannon

    (@bethannon1)


    Support Team Volunteer Coordinator

    We use Holler Box on a client site that is using the WP Media Offload (by Delicious Brains) as a CDN. This plugin uploads any image uploaded through the page/post editor or media library, and then immediately deletes that image from the websites media library, rewriting the URL with a CDN URL.

    Images are uploading via pages and posts and appearing just fine. Everything seems correct with this configuration.

    Inside Holler Box however – whether an image is uploaded in the Holler Box editor page OR inserted via the media library – Holler Box tries to display this image using the original non-CDN URL. And of course, because the media offload configuration deletes the image from the media library after offload, Holler Box displays a broken image. The CDN URL is saved inside the Holler Box item, but somehow Holler Box is overriding that url to try to show the non-CDN image.

    So for instance: I uploaded this image, and this is it’s CDN url (which appears in the meta in the media library in the dashboard, AND in the Holler Box editor in text view):
    https://cdn.domain.org/wp-content/uploads/2021/03/10093415/03john.jpg

    But Holler Box on the front end tries to load:
    https://domain.org/wp-content/uploads/2021/03/03john.jpg

    I think you might be pulling the guid from the image post, but I’m not really sure where the image URL should be pulled from to get the correct one that displays in the media library.

    Is there any help you can give me for troubleshooting fixing this?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.