Support » Plugin: LiteSpeed Cache » CDN font-faces don’t load

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi @romainguillaume, could you please provide your Report Number, found in WP Admin > LiteSpeed Cache > Report, for us to check the plugin setting?

    Thread Starter romainguillaume

    (@romainguillaume)

    TEPDETCF

    Thread Starter romainguillaume

    (@romainguillaume)

    I am trying with different sites, .htaccess locations, domains, subdomains but nothing works. It also seems that the .ico is not willing to load neither.

    Hi @romainguillaume,

    I’ve checked .woff and .ico are not on LiteSpeed Cache > Setting > CDN > Include File Types, please try to add these two extensions and purge the cache to see is it work.

    Thanks,
    Stanley

    Thread Starter romainguillaume

    (@romainguillaume)

    I tested it but I need my site display right so I removed those file types. It is more as if Litespeed server does not read htaccess values.
    A php script running get_headers() don’t return Access-Control-Allow-Origin as noted in htaccess.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please try

    <FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|font\.css)$">
    Header set Access-Control-Allow-Origin "*"
    </FilesMatch>

    Best regards,

    Thread Starter romainguillaume

    (@romainguillaume)

    Even without the filematch condition headers do not allow any cross origin loading for fonts and icon.
    The vhost seems Ok to read the .htaccess with

        rewrite  {
          enable                  1
          autoLoadHtaccess        1
        }
    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    OpenLiteSpeed only reads rewrite rule in .htaccess

    To set header on OLS, please check this post

    Best regards,

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘CDN font-faces don’t load’ is closed to new replies.