• Resolved assa



    I have a problem with configuring the CDN Base URL.
    (1) If I leave it blank all images are loaded from S3 bucket address:
    myS3bucket/2019/02/myimage.png . There is no issue.

    (2) If I input my AWS Cloudfront CDN domain (which I set on the S3 bucket) in the CDN Base URL field in the plugin then the images are not loaded. CDN domain is being prepended by my website domain as following:
    If I try to open the address myawscloudfrontcdndomain/2019/02/myimage.png there is the image, so my AWS CDN is definitely working but I have no idea why the URL address is prepended with my domain.
    Can you tell me what is the issue?

    (3) Third option I tried is inputting my CloudFront CDN domain not into your plugin but as a CDN in WP-Rocket cache plugin(+adding myawscloudfrontcdndomain cname to my DNS).
    I cannot get the images loaded & get the following address: myawscloudfrontcdndomain/wp-content/uploads/2019/02/myimage.png
    As I mentioned in no. 1&2 the files are stored in myS3bucket/2019/02/myimage.png and served through myawscloudfrontcdndomain/2019/02/myimage.png
    There is no wp-content & upload folders. Is there a way to store images in wp-content/uploads?
    Honestly, I don’t know which is more efficient no 2 or no 3, but I kind of used to setting CDN in WP-Rocket.

    I appreciate your help

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘CDN base URL settings’ is closed to new replies.