Support » Plugin: Speed Kit » CDN and service worker not working

  • Resolved Leopard-Lady

    (@leopard-lady)


    Hello again,
    I’m back with issues I can’t figure out. I tried the Github chat from your dashboard and no response. Thought I’d try here instead.

    Here’s what has happened and is now happening:

    I installed and enabled your wordpress plugin yesterday. I am setting up a new site. It is only me and page speed testers accessing it. The plugin is telling me “Your current plan has been exceeded. Therefore, Speed Kit is not activated for your website.” But on my Baqend Dashboard it shows plenty of use still available.
    My dashboard shows:
    0% used of 4GB
    1% used of 150,000

    Then . . . I went to my account tab in the plugin to get my app name for the chat and that step seems to have cleared the error. The plugin is renabled now.

    Now when I run gtmetrix for page speed it is no longer recognizing the CDN like it was before.

    QUESTION: When using your plugin, what is our CDN Domain, please? I tried the Predefined domains from the dashboard, but that 404’s.

    Just ran a Chrome Lighthouse audit. Was having this same issue with audits last night. My site does NOT register a service worker with your plugin.

    QUESTION: Do I need to set up the PWA Manifest in the dashboard to get the service worker to fire correctly?

Viewing 1 replies (of 1 total)
  • Plugin Author baqend

    (@baqend)

    Hi @leopard-lady,

    sorry for responding late to your questions!
    Our most active community chat is in this Gitter thread, there you can get the fastest responses!

    Now to your questions:

    I installed and enabled your wordpress plugin yesterday. I am setting up a new site. It is only me and page speed testers accessing it. The plugin is telling me “Your current plan has been exceeded. Therefore, Speed Kit is not activated for your website.” But on my Baqend Dashboard it shows plenty of use still available.

    This seems to be an error on our side maybe – could you tell me your Baqend App’s name? Then I could take a look into its log files.

    QUESTION: When using your plugin, what is our CDN Domain, please? I tried the Predefined domains from the dashboard, but that 404’s.

    I am sorry, but there is no CDN domain available – your website is not uploaded to our servers for speed up but rather cached there, so subsequent requests will be faster. If your account really was exceeded the other day then the CDN which we are using to deliver your website faster to users is not delivering any content and the Service Worker in your users’s browsers will be turned off.

    QUESTION: Do I need to set up the PWA Manifest in the dashboard to get the service worker to fire correctly?

    No, the Service Worker is able to function without a PWA Manifest (actually, this is really just needed if you want your website to become a web app). I guess the issues which you have are related to your disabled Service Worker. If you like, I can look into more detail in your issues if you give me your Baqend App’s name and your WordPress’s URL! I will be glad to help you!

    Kind regards,
    Konstantin from Baqend

    • This reply was modified 1 year ago by  baqend.
Viewing 1 replies (of 1 total)
  • The topic ‘CDN and service worker not working’ is closed to new replies.