Support » Plugin: Dave's WordPress Live Search » caution update broke search

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Dave Ross


    Sorry, but you’ve provided no information about your site, your theme, what other plugins you’re using, or even what version of WordPress you’re running. I’m not saying you’re not having problems, but version 3 of this plugin has been running on my site and others’ through an obnoxiously long alpha/beta cycle. It works, but there’s obviously something on your site that’s causing issues. Can you provide any additional information that might help reproduce or troubleshoot the issues you’re having?

    Mine stopped working too, no spinning wheel though, it just doesn’t work.

    My Site

    Plugin Author Dave Ross


    Thanks, Wanderer.

    I noticed you’re pulling in an older version of jQuery (1.4) from Google’s CDN. A selector I’m using is compatible with the versions of jQuery that shipped with the last few WordPress updates, but apparently fails on 1.4.

    It should be easy enough to work around. I’ll see what I can do.

    Plugin Author Dave Ross


    3.0.1 should clear that up for you. Be sure to empty the cache if you’re using a caching plugin.

    Let me know if it’s still not working for you.

    – Dave

    hi, at that time i was making an observation about how often that happens to me. i love your plugin. I can not get new version to work. deleted it reinstalled. using latest everything. tried other things.

    thanks Dave.

    [Please stop posting in uppercase. It’s the electronic equivalent of shouting and is considered quite rude. Post de-capped.]

    I should say the search in question is located at very top of all posts.

    so no help because my cap button was accidentally on for half my pervious message?

    hey well, it turns out a sudden conflict with popular wp-socializer…

    Again this is only after the update.

    Please advise.

    Plugin Author Dave Ross


    I checked out your site the other night and found that same conflict, too. WP-Socializer is inserting its code into the AJAX response before the search result data even renders. It started because I’m calling WordPress’s the_excerpt filter now so shortcodes and the like are processed correctly. But it’s like some template in WP-Socializer is echoing out the code for the social buttons instead of returning.

    I don’t know much about WP-Socializer — does it allow for custom templates or are you just using one of the built-in ones? I didn’t have much time to play around with it this week between work & being sick. I figured I’d try out some of the WP-Socializer options and see if I could reproduce it this weekend.

    Plugin Author Dave Ross


    Well, I just spent an hour trying a bunch of different WP Socializer options and checking out their message board, and I can’t reproduce this. No matter what I do, the Socializer code never shows up before the results data on my test site. Even when I tell Socializer to put share buttons in the excerpt, they show up right where they’re supposed to be in the middle of the search box. It’s kinda silly-looking, but it’s doing exactly what I asked it to, I guess.

    There has to be something special in how you have it set up. Maybe something custom you added to your theme?

    Dave, thanks for going to the wall when you don’t feel so good, I appreciate that a lot very touching. So I really need my social buttons but when push came to shove, I kept your Live Search and disabled Socializer, I like LS that much. I imagine that problem with Soclzr may have been causing me other issues as well. Ideally I would like to keep the soclzr so I am the posting code I use to manually customize the buttons in hope you catch the error.

    holy bananas, I hope it is ok to post all this code here.

    <div class=”wp-socializer-buttons clearfix”>
    <span class=”wpsr-btn”>{facebook-like}</span>
    <span class=”wpsr-btn”>{retweet-bt}</span>
    <span class=”wpsr-btn”>{reddit-2}</span>
    <span style=”float:right”>

    <iframe src=”″ scrolling=”no” frameborder=”0″ style=”border:none; overflow:hidden; width:70px; height:30px;” allowTransparency=”true”></iframe>

    Follow @TheCountNews
    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);;js.src=”//”;fjs.parentNode.insertBefore(js,fjs);}}(document,”script”,”twitter-wjs”);</script></span>

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘caution update broke search’ is closed to new replies.