Support » Plugin: Disable Gutenberg » Causing slow query in Woocommerce plugin?

  • Resolved diegpl

    (@diegpl)


    https://wordpress.org/support/topic/2-6-0-update-bug/#post-13131217
    That is what I inserted in Woocommerce forum. Please, take a look and let me know if that could be cause by your plugin. Thank you! ๐Ÿ˜‰

    —–

    I do not get an error but a slow query through Query Monitor plugin, and I do not even work with Gutenberg, I even have the โ€œNo Gutenberg โ€“ Disable Block Editor โ€“ Back to Classic Editorโ€ active.

    Automattic\W\B\Installer->maybe_create_table()
    wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/Installer.php:93
    Automattic\W\B\Installer->maybe_create_tables()
    wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/Installer.php:64
    Automattic\W\B\Installer->install()
    wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/Installer.php:27
    do_action(โ€˜admin_initโ€™)
    wp-includes/plugin.php:478

    That is happening in the last version (4.3.0).

    Is there a way to fix this slow query I believe should not even run actually? Does someone know if the team is already taking a look or should we talk about how to improve the code ourselves and give it to the team? Tks! ๐Ÿ˜‰

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Hi @diegpl, glad to help but I’m not able to replicate the issue on default WP, so there is nothing really I can do to help. It sounds like you have some heavy plugin loads happening, which will impact performance. Best advice is to go through your plugins and see if there are any conflicts, errors, warnings, clues, etc. Feel free to post again with any further questions, feedback, etc. Thank you.

    I have the same issue on WordPress multisite with more than 50.000 tables in database. The WooCommerce is only enabled on main site.

    Plugin Author Jeff Starr

    (@specialk)

    @growtale the plugin is not tested on Multisite, not recommended. Try Classic Editor instead.

    It seems the problem is not related to your plugin @specialk because even with your plugin disabled the problem persists. Any idea @growtale ? Tks! ๐Ÿ˜‰

    @growtale I am talking about this issue at https://wordpress.org/support/topic/2-6-0-update-bug/ as well. I still do not know if the issue could be related of having this plugin enabled when Woocommerce was setup. I will let you guys know about any news ๐Ÿ˜‰

    @specialk I just disabled your plugin and reactivate a website with Woocommerce and error persists. I guess it is proved the problem is not related to your plugin, right? Tks! ๐Ÿ˜‰

    Plugin Author Jeff Starr

    (@specialk)

    Yeah DG plugin is super lightweight and does only a few things. Very unlikely that it could cause any slowness.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.