Support » Plugin: Bible Reading Plans » Causing issue with other plugins

  • Resolved darivera1014

    (@darivera1014)


    I have downloaded this plugin and started using it. When this plugin is activated, I am unable to open a page with Elementor. When I deactivate this plugin, Elementor opens with no issues. Also, I use another plugin that reveals other issues such as unable to add/change feature image to a post.

    Please advise.

    PS… I LOVE THIS PLUGIN. What a tremendous blessing!!! Thank you!!!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author drmikegreen

    (@drmikegreen)

    Thanks very much for you good words about this plugin.

    I will try to resolve this issue as soon as I’m able.

    Plugin Author drmikegreen

    (@drmikegreen)

    Hi!

    I installed Elementor on a site which only had the Bible Reading Plans plugin and a scroll to top plugin active.

    I then created a test page with Elementor. I had no problem opening that page.

    The page I created was very simple. So perhaps the problem only occurs with more complex pages. Perhaps you could send me the page you can’t open.

    On the other hand, perhaps the problem comes from another plugin. You mentioned another plugin that reveals other issues such as unable to add/change feature image to a post. Perhaps that is the plugin with the conflict withthe Bible Reading Plans plugin.

    I try to get to the bottom of this.

    Thread Starter darivera1014

    (@darivera1014)

    You are right!!!! It was another plugin. I found the culprit! Thank you. Sorry for making you do unnecessary work.

    I have one question, if I make a website for a church and want to use this plugin for the Bible on their website, can I reuse my API keys? Or, do I they need to sign up for API keys?

    Plugin Author drmikegreen

    (@drmikegreen)

    Great! I’m glad you found the problem. And that it wasn’t my plugin. 🙂

    It would be best if each organization which uses the plugin has their own API keys, even if you find that your API keys work for their sites. That helps the providers to know who are using their APIs. In addition, it is possible that some of the providers will — or already do — add checks to make sure only sites which have signed up for their key are able to access their content.

    Thread Starter darivera1014

    (@darivera1014)

    Thank you. Unfortunately, I do find another issue. And, this seems to be at least triggered by this plugin. I am using the Church Center plugin. When Bible Reading Plan plugin is activated, I am unable to do some functions on the Church Center Plugin (change/add image). When I deactivate the Bible plugin, the Church Center plugin works appropriately. I’ve tested all other plugins, but, they don’t seem to have any effect on the church center plugin.

    I created a video to clarify the issue: https://drive.google.com/file/d/1uOJ8YXaZP4DuxrdIBVerhXeQw1R7xZLx/view

    Plugin Author drmikegreen

    (@drmikegreen)

    Well, I’ve installed the Church Center plugin and find that I have problems with it no matter whether or not the Bible Reading Plans plugin is activated. That is likely due to my unfamiliarity with the plugin and not having time to gain familiarity.

    I do note, however, that I’m getting errors like:
    PHP Notice: Undefined offset: 1 in .../wp-content/plugins/bible-reading-plans/bible-reading-plans-class.inc.php on line 1485, referer: https://www.widgetchuck.com/card/
    That would seem to indicate that something in the Church Center plugin is trying to access code inside the Bible Reading Plans plugin.

    Perhaps you could contact the authors of the Church Center plugin about this. I could try to figure out what in their code causes it to jump inside the Bible Reading Plans plugin code. It might, however, be easier for them to do so.

    Thread Starter darivera1014

    (@darivera1014)

    Hey there. I pray all is well. I am having a similar issue again. When this plugin is activated, I am unable to open a page in Elementor. This time, I deactivated all the plugins except this plugin and Elementor. And, I changed the theme to twenty-one default theme. And, still the issue was not resolved. I, also, tested this with different pages. On all pages, I was unable to open with Elementor.

    The page I am attempting to open is https://webezoid.com/fathers-house-church/bible-reading-plan/

    Thank you for your help!!!

    Plugin Author drmikegreen

    (@drmikegreen)

    Thanks! I’m doing well, with lots of visits from home health care and better care yet by my wife.

    The content retrieved from the remote APIs does not load on pages when editing with Elementor or other visual editors (like Divi Builder) or any editor, to my knowledge.

    I’ve never delved into this, since one cannot edit content retrieved from the remote APIs. It is supplied by the owner of the API in whatever form they choose.

    One can change the styles by adding those changes to the styles local to the site.

    Thread Starter darivera1014

    (@darivera1014)

    Sorry. I don’t think we’re talking about the same thing. Or, I just don’t speak your language 🙂 haha.

    To clarify, I made a video showing the issue.

    https://drive.google.com/file/d/1F9zomnN6NjOiOwOER7kQhbQgJYxuk-lT/view

    Plugin Author drmikegreen

    (@drmikegreen)

    I’m sorry. I didn’t read your previous email carefully enough. (I’m also sorry for the detailed response about my health. I confused you with someone else.)

    If I now understand you correctly, you cannot edit any page in your site with Elementor if the Bible Reading Plans plugin is active.

    I’ve tested for this behavior on one of my test sites and cannot observe it. I can edit just fine with Elementor when the Bible Reading Plans plugin is active.

    It is possible that my test pages are too simple to put this to a real test. Perhaps you could create a simple test page to see whether or not you can edit it.

    Plugin Author drmikegreen

    (@drmikegreen)

    By the way, are you using the latest version (1.0.4) of the plugin? I made some changes in Version 1.0.3 that took care of another conflict between plugins in Dashboard.

    I’m also looking into other changes which could fix this issue…

    Plugin Author drmikegreen

    (@drmikegreen)

    I’m shooting in the dark. since I cannot replicate the problem on my test site. I have, however, made some changes which could clear up the kind of problems you are seeing.

    Are you able to add a file to the /wp-content/plugins/bible-reading-plans directory? If so, I’ll send you a test file for this directory. If not, I’ll send you a beta upgrade of the Bible Readings Plug. In either case, I hope you can test and that you will find there are no longer any conflicts.

    Plugin Author drmikegreen

    (@drmikegreen)

    By the way, Ihad sent the last several posts as emails over a period of several days. It appears you didn’t receive them. I, therefore, posted them here in the past few minutes…

    Thread Starter darivera1014

    (@darivera1014)

    Hello!

    Thank you for the responses. I was using 1.0.3. But, I just updated to your 1.0.4. The problem still exist. Please send me the beta update. You can send it to info@webezoid.com

    Plugin Author drmikegreen

    (@drmikegreen)

    This is now resolved in Version 1.0.5.

    Thanks very much for finding this problem and help with the testing of the resolution.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Causing issue with other plugins’ is closed to new replies.