Support » Plugin: Google Analytics » Causing fatal error after updating

  • Resolved immaterial

    (@immaterial)


    The plugin is causing a fatal error and white page of death after updating to version 2.0.0. Any clue?

Viewing 15 replies - 16 through 30 (of 40 total)
  • I’m getting the same error. I’m on a call with a tech rep from my hosting company

    I tested the updated plugin for those of us with older PHP installed. It seems to be working, and I do not have any more PHP errors.

    One problem I am having: I am not able to authenticate my account with Google. I had to manually authenticate using my tracking ID.

    – Brent

    • This reply was modified 2 years, 8 months ago by  bowend3c.

    Log in to your site using FTP. Then navigate to wp-content/plugins.

    Rename the googleanalytics folder to googleanalytics1

    They try logging in to your wordpress dashboard. It should have automatically deactivated the Google Analytics plugin.

    – Brent

    • This reply was modified 2 years, 8 months ago by  bowend3c.
    Plugin Author ShareThis

    (@sharethis)

    @bowend3c Could you explain a bit more or send the screenshot. What was the issue when you tried to sign in with google? Did you copy and paste the token?

    Hi all,

    Thank you for reporting on this issue, we have found a solution and pushed version 2.0.1 live. The issue came from older PHP versions on your server, please update to the latest version (2.0.1) and the plugin should work just fine now!

    New error ….

    When I upload 2.0.1 I get this message – Google Analytics 2.0.1 plugin has joined the ShareThis family. A host of new features has been added in this version, including Google Analytics dashboards and roles management, and the update requires agreeing to the privacy policy and terms of use to enable them. I accept

    Pressing the “I accept” button gives me a “Page not found” and returns me to the website home page. There appears no way to accept the policy

    Plugin Author ShareThis

    (@sharethis)

    @goscoutuk just uninstall the plugin from WP settings and install again, it should go away.

    Also could you please change your review from 1 star, the bug you had was just because of the old PHP version on your hosting, we have fixed it in an hour so 5-star reviews would really help.

    • This reply was modified 2 years, 8 months ago by  ShareThis.
    • This reply was modified 2 years, 8 months ago by  ShareThis.

    @sharethis – Sure. Here you go:

    https://drive.google.com/drive/folders/0B0OjccXZGmuhMzY2TEZrcTFtSWc?usp=sharing. There are two screenshots, one before, one after. Basically what happens: I click on it, the screen darkens, and nothing happens.

    Let me know if I can help you debug any further.

    – Brent

    • This reply was modified 2 years, 8 months ago by  bowend3c.
    Plugin Author ShareThis

    (@sharethis)

    @bowend3c thanks for the screens, try in another browser. It should be like a pop up so maybe you have the pop-up blocker interfering with it.

    Nope … uninstalled, reinstalled and now have no option to accept at all. The plugin is still asking me to accept, but offering me no box or button to press

    With nearly a hundred sites to do, this simple upgrade is turning into a nightmare. If I have to manually delete and install the plugin again for each site, it’s going to take too long. Please fix this and let me know when a stable version is online before I attempt to update again.

    • This reply was modified 2 years, 8 months ago by  GoScoutUK.

    Tried it in three different browsers (Safari, Firefox, and Chrome). Same result. I turned off my popup blockers in all three browsers.

    – Brent

    @brandon & @sharethis: so we still have to manually fix this problem?

    And how can this issue be marked “Resolved” if the problem is still occurring, as GoScoutUK and bowend3c’s experience show?

    I’m still waiting to hear from @brandon whether there is no way to access the WordPress admin panels directly.

    Is FTP and via hosting service the only options?

    @dokrugby – It’s not a difficult manual fix, but you’re going to have to change the name of the googleanalytics folder in order for your wordpress installation to allow you to log in to the dashboard. Once you do that just go back and install an older version of the plugin: https://wordpress.org/plugins/googleanalytics/developers/

    The plugin developer will figure it out in a few days and push us a new update. In the meantime if you want to be able to access your dashboard, you’re going to have to do the manual fix.

    – Brent

    Hi dokrugby and bowend3c,

    Thanks for getting back to us, we’re still looking into this.

    For now the best solution to get into the WordPress admin panel is by removing the plugin via FTP. I left details in my previous post and it is very simple to remove and re-add the old version.

    Sorry we do not have a better solution at the moment, but we are continuously debugging and your feedback has been enormous help!

    We appreciate your patience and will update you as we go along.

    Yes, both the 1.07 and the PHP before 5.5 patches work fine in my site http://thescoopclayton.com/

    • This reply was modified 2 years, 8 months ago by  amikeliunas.
Viewing 15 replies - 16 through 30 (of 40 total)
  • The topic ‘Causing fatal error after updating’ is closed to new replies.