Support » Plugin: WooCommerce PayPal Checkout Payment Gateway » Causes login via WooCommerce Account page to fail

  • Resolved commdoc

    (@commdoc)


    Previously hassle-free. This plugin has apparently started to have a conflict within the last two weeks.

    Issue: login via WooCommerce Accounts page fails. Submitting correct credentials simply reloads page. (NB. login via …/wp-login still succeeds as expected. Once logged in, Accounts page displays account info, as expected.)

    Systematically disabling plugins to find source of problem, was surprised to find that disabling this (official Woo) plugin made the Accounts page function as expected.

    Until this is resolved, must choose between either accepting Paypal payments or allowing customers to login to their accounts.

    Advice appreciated.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Sean Cull

    (@seanreloaded)

    Automattic Happiness Engineer

    Hi there,

    > Issue: login via WooCommerce Accounts page fails. Submitting correct credentials simply reloads page. (NB. login via …/wp-login still succeeds as expected. Once logged in, Accounts page displays account info, as expected.)

    Just so I understand the issue, you’re saying that if you have only the latest versions of WooCommerce (3.4.3) and WooCommerce PayPal Checkout Payment Gateway (1.6.1), it won’t allow you to log into your site at /my-account/ ?

    If so, have you tried temporarily changing your theme to a default WordPress one? Reason I ask is because I’m able to successfully log in with no issues when using a default WordPress theme, and the latest plugin versions.

    Yes, that summarises the issue well. Even when they are the only two plugins activated, login via the page with the my-account shortcode fails

    The site runs on Royal by 8theme
    Have also tested with twenty-seventeen: yes, the problem persists.

    verified: WordPress 4.9.7
    verified: WooCommerce 3.4.3
    verified: WooCommerce PayPal Checkout Payment Gateway 1.6.1

    As an aside, just noticed that PayPal icon now shows up unexpectedly in the fixed header with the cart item count icon. This throws out the header formatting so it displays when it should be hidden. (As a quick-fix, I’ve hidden the button with CSS.)

    I too am experiencing this issue. When this plugin is enabled, the WooCommerce login is not working.

    Same problem, using Storefront.
    In the console i see this: https://jdlefou.tinytake.com/sf/Mjc3ODI2MF84MzMzOTI3
    3 calls to https://www.paypal.com/webapps/hermes/api/logger.

    I have this calls in all pages.
    Note: doesn’t work Password Reset too

    WordPress 4.9.7 with Storefront
    WooCommerce 3.4.3
    WooCommerce PayPal Checkout Payment Gateway 1.6.1

    • This reply was modified 1 year, 4 months ago by jdlefou.

    I’m experiencing the same problem over here. The login action does nothing – the page is simply refreshed. New registration and forgotten password does not work either.

    Tried disabling all plugins except WooCommerce and PayPal Checkout, but the problem persists. Disabling the new Smart Payment Buttons in the settings is a temporary fix that seems to work for now.

    Good catch, @lykkelig.
    Confirmed: disabling Smart Payment Buttons seem to fix the conflict.
    Also stops the button unexpectedly appearing in fixed header with cart shortcut.
    Hope this is wrinkle is ironed before smart buttons become the default!

    I also have this issue and it is also fixed by disabling ‘Smart Buttons’.

    Same here. I’m wondering if the PayPal Standard option that comes with WooCommerce will be sufficient for accepting PayPal, and why this plugin is necessary.

    Sean Cull

    (@seanreloaded)

    Automattic Happiness Engineer

    Hi digitaleffex,

    Have you seen the documentation page for this plugin? It explains the difference in the checkout process compared to PayPal Standard:

    https://docs.woocommerce.com/document/paypal-express-checkout/#section-9

    I’m also experiencing the exact same thing. I went over all the plugins I have and the one that causes all the registration/login problems is WooCommerce PayPal Checkout Payment Gateway.

    I can also confirm that when disabling Smart Payment Buttons in the plugin the problem seems to be solved for now.

    I am also having this issue. Going to submit it at the github.

    Plugin Support Hari Shanker R

    (@harishanker)

    Automattic Happiness Engineer

    Hi folks! Thanks for reporting this to us. We already have an open bug report about this: https://github.com/woocommerce/woocommerce-gateway-paypal-express-checkout/issues/464

    We hope to get this resolved soon!

    Can confirm this is also happening to me, running Genesis child theme.

    Plugin Support Luminus Alabi

    (@luminus)

    Automattic Happiness Engineer

    @commdoc,

    If you update to the most recent version of the plugin you’ll find that this issue has been fixed.

    I’ll go ahead and mark this as resolved now. If you have any further questions, feel free to start a new thread.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Causes login via WooCommerce Account page to fail’ is closed to new replies.