Support » Plugin: Smush - Lazy Load Images, Optimize & Compress Images » Cause “Defer offscreen images” in PageSpeed Insights

  • Resolved haydenng664

    (@haydenng664)


    Hi,

    I am using Instagram Feed Pro with Smush, but my Instagram feed images don’t appear after I enabled the “Disable JS Image Loading”.

    If I disable “Disable JS Image Loading”, then it works again. My intention is to lazy load the Instagram feed so that it doesn’t increase my website’s load time.

    Please help!

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter haydenng664

    (@haydenng664)

    Please find it in the near bottom of my homepage

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @haydenng664

    I hope you are doing well.

    I installed the Free version and made some tests on my website.

    Do you have the Load initial posts with AJAX enabled?

    If so, can you try to disable it and it should make the Lazy Load work as expected, as the post is loading from Ajax when the Smush check the DOM to lazy load images those images doesn’t exist so the plugin won’t add the Lazy Load tag.

    Another option is using the Smush > Lazy Load > Enable native lazy loading & Enable the Disable JS Image Loading.

    Let us know the result you got.
    Best Regards
    Patrick Freitas

    Thread Starter haydenng664

    (@haydenng664)

    I was able make the my instagram feed show up now. But the Defer offscreen images is still showing up in PageSpeed Insights.

    What do I do?

    Thread Starter haydenng664

    (@haydenng664)

    Looks like Smush couldn’t lazy load Instagram Feed pictures? I tried it with wprocket lazy loads it could lazy load Instagram feed pictures.

    But I prefer Smush’s lazy load.

    Any idea?

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @haydenng664

    Can you let us know which configuration you ended in the Instagram plugin?

    It worked fine for me on both cases that I reported in my latest reply:
    https://wordpress.org/support/topic/cause-defer-offscreen-images-in-pagespeed-insights/#post-14444320

    Best Regards
    Patrick Freitas

    Thread Starter haydenng664

    (@haydenng664)

    Instagram Feed
    Load initial posts with AJAX – Off
    Disable JS Image Loading – On

    SMUSH
    Enable native lazy loading – On

    Here is my relevant setting.

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @haydenng664

    Could you please send me an email to contact@wpmudev.org using this template:

    Subject: “Attn: Patrick Freitas”

    Message: link back to this thread for reference

    Best Regards
    Patrick Freitas

    Thread Starter haydenng664

    (@haydenng664)

    Hi, I just did.

    Thanks. Let me know if there is an update on this. 🙂

    Thread Starter haydenng664

    (@haydenng664)

    Hi,

    I am still waiting for a solution to this. Thanks!

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @haydenng664,

    I have responded to your email so please check your inbox and get back to us there.

    P.S. Please don’t bump your tickets per forum rules. We provide free support for our plugins here and while we’re trying to get back in a timely matter we can’t instantly respond to everyone.
    If you require instant support you can consider getting a membership on our site that includes live chat support.

    Cheers,
    Predrag

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @haydenng664

    I hope you are doing well and safe!

    We haven’t heard from you in a while, I’ll mark this thread as resolved.

    Feel free to let us know if you have any additional question or problem.

    Best Regards
    Patrick Freitas

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.