Support » Plugins and Hacks » WooCommerce » [Resolved] Category Widget not Working after 2.0.15 upgrade

[Resolved] Category Widget not Working after 2.0.15 upgrade

  • lickthespoon


    After upgrading to 2.0.15 earlier today none of the Woocommerce layered Nav or Category widgets are working. The category widget shows ‘no categories available’.
    I’ve tried removing them and reading them – that doesn’t work.
    I’m not trying to regress back to 2.01.14

    As an aside why are all of the comments being removed from similar posts – it makes it look like the problem is less widespread than it obviously is? I know software is a complex thing but it seems that the woocommerce widgets aren’t working with the upgrade unless it’s a theme releated issue?


Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi


    Forum Moderator

    Posting in an existing topic is not only rude but causes multiple problems for those who are trying to answer. As per the Forum Welcome, please post your own topic.



    It looks like Mike Jolley has a fix coming for this in a different thread.

    In the meantime as a workaround I followed the rollback advice suggested to 2.0.14. [Comments re moderation removed]

    To roll back
    – I downloaded 2.0.14 https://github.com/woothemes/woocommerce/releases
    – FTP’d via Cpanel to my plugins directory
    – extracted all – it unzips to 2.0.14
    – renamed woocommerce folder to woocommerce-2.0.15
    – renamed the uploaded woocommerce-2.0.14 to woocommerce
    – seems to work on a quick test as no database changes

    it looks like a fix may be coming here

    Plugin Author Mike Jolley


    Hi guys,

    It seems there were some merge errors in the 2.0.15 release which caused categories and attribute labels to be hidden. We’ve resolved this and pushed out 2.0.16 to resolve these issues.

    Please update to 2.0.16 to fix the category/attribute display issues. Apologies for any inconvenience caused.





    Oh dear – I just tried the 2.0.16 upgrade and now my top menu has all of the categories displayed in one giant menu. I’ve tried deleting the cache etc and rolling back to 2.0.14 but nothing so far will fix it!



    It looks like 2.0.16 has reset all of my Woocommerce pages and I have to reselect them all?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Category Widget not Working after 2.0.15 upgrade’ is closed to new replies.
Skip to toolbar