Support » Plugin: Yoast SEO » Category Titles missing

  • Resolved qaws

    (@qaws)


    Hi, I’m using v14.2 and the page Titles are not displaying correctly for categories. They’re not including the name of the category.

    Example:
    I have a page at “//mysite.com/category/tennis” which automatically lists all Posts in the “tennis” Category.

    In my browser, my page title as displayed on the actual Window bar is “| mysite name”.

    If I go to the “Edit Category” screen for this category, it has a name and a slug, and in the Yoast settings it has “Category Separator SiteName”, but the preview is not displaying the Category name, and this is reflected in me not seeing it in my browser Window title either.

    My other Pages display fine. It’s just with the auto-generated Category pages.

    Any help appreciated. Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @qaws,

    Thank you for reaching out! We apologize you are having issues with the plugin.

    In order to troubleshoot, would you be able to share both a screenshot of what you have configured in a category archive and the URL so we can see what the output of Yoast is and if it differs from what you’ve entered? We ask since we couldn’t replicate this issue in a test environment.

    Furthermore, can you please also confirm that next to running the latest Yoast version, that all other plugins, themes and WordPress itself are up to date? If it is, can you please run a conflict check to see if the issue persists when Yoast SEO is the only active plugin and you are using a default theme? You can find more details on how to do this here: https://yoast.com/help/how-to-check-for-plugin-conflicts/.

    Thanks.

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @qaws;

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new forum topic. Thank you!

    Thread Starter qaws

    (@qaws)

    After much sarching through code and settings, I finally found the cause. It was Yoast!

    On the Search Appearance > Taxonomies > Categories section, my “SEO Title” field had in it:
    Category Separator Site_Title

    and it looks like some time in the past you’ve removed “Category” as a valid snippet.

    I updated this using the “Insert snippet variable” to “Term Title”, and this fixed it immediately.

    Now it is configured as:
    Term_Title Separator Site_Title
    and this works correctly.

    It might be worth you auto-replacing anyone’s value of “Category” with “Term title” in the next update. Whilst “Term hierarchy” is also available, “Term title” is the direct replacement of what “Category” was, so it won’t have any negative impact on people’s sites.

    • This reply was modified 1 year, 5 months ago by qaws.
    • This reply was modified 1 year, 5 months ago by qaws.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Category Titles missing’ is closed to new replies.