WordPress.org

Support

Support » How-To and Troubleshooting » Category search not working as expected?

Category search not working as expected?

  • i am trying to right a plugin, part of that plugin it needs to search to see if there is a category with a specific name, and it does cant find it even though it is there.

    i am using the “get_categories()” to list all categories, but it is not listing all the categories, instead it outputs:
    Array ( [4] => stdClass Object ( [term_id] => 1 [name] => Uncategorized [slug] => uncategorized [term_group] => 0 [term_taxonomy_id] => 1 [taxonomy] => category [description] => [parent] => 0 [count] => 1 [cat_ID] => 1 [category_count] => 1 [category_description] => [cat_name] => Uncategorized [category_nicename] => uncategorized [category_parent] => 0 ) )

    now, when in wp-admin and under categories, it shows the categories as there.

    one of the categories is called: “Coke, Coal & Natural Gas”, now if i do a search for that category, it says no items found…

    if i search for: “Coke, Coal & ” it works, but not if i search for “Coke, Coal & N”

    is this a bug? is it intended? can anyone point me in the right direction?

    [Moderator Note: No bumping. If it’s so urgent that you cannot wait longer than 2 hours, consider hiring someone.]

Viewing 1 replies (of 1 total)
  • its been 4 days,

    does anyone know if this is a bug or not? or is it a intended feature that the search does not work?

Viewing 1 replies (of 1 total)
  • The topic ‘Category search not working as expected?’ is closed to new replies.
Skip to toolbar