Support » Plugin: Smarter Navigation » Category restriction problem, seems like a bug

  • WordPress 3.9.1
    Smarter Navigation 1.3.2

    Homepage is a custom template with a WP_Query getting the 20 most recent posts.

    Here is the sequence of things, in order:

    1. On a fresh visit to the site (no session, no cookies)
    2. Visit homepage
    3. Click on any blog post
    4. Smarter Navigation works as expected, not locked into a category as homepage is category agnostic.
    5. Visit a category archive page
    6. Visit a category post via that page
    7. Smarter Navigation works as expected, locked into the category I came in from
    8. Visit homepage again
    9. Click any post
    10. Smarter Navigation works as expected, not locked into a category, UNTIL I hit a post that was in the category I visited the archive of…

    So, what seems to be happening is that when you come back to the homepage after visiting a category archive, the session cookies don’t get set to the homepage, rather they stay set to the previous category archive page.

    What happens then is, when you get to a post that is in that category, the previous next functionality switches from category agnostic to being locked into that category.

    Seems like a bug, but it also could be due to using WP_Query instead of the standard loop? Hoping the developer has a quick fix for this.

    Thanks for a great plugin, seems to work very well other than this one little hiccup.

    https://wordpress.org/plugins/smarter-navigation/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter noahkuhn

    (@noahkuhn)

    My problem is fixed by changing line 23 in /smarter-navigation/main.php to be

    $clear_condition = is_front_page();

    Seems like that should default to clearing on either the homepage or the main blog page no?

    Thread Starter noahkuhn

    (@noahkuhn)

    And thus the default would be

    $clear_condition = ( is_front_page() || is_home() );

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Category restriction problem, seems like a bug’ is closed to new replies.