Support » Plugin: WooCommerce » Category pages slow

  • Resolved katmacau

    (@katmacau)


    Hello. My woo category pages are running slow. WP Query Monitor is telling me that ‘update_meta_cache()’ is the slow query. Eg on a page of 25 products its running 10530 queries.

    How can I reduce this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Mirko P. woo-hc

    (@rainfallnixfig)

    Hi @katmacau,

    This kind of problem is usually caused by a conflict with your theme or with another plugin. The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce
    • Repeat the action that is causing the problem

    If you’re not seeing the same behavior after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated.

    Reactivate the theme first and check again. Then, go on and reactivate your other plugins one by one, testing after each, until you find the one causing conflict.

    You can find a more detailed explanation on how to do a conflict test here: https://docs.woocommerce.com/document/how-to-test-for-conflicts/.

    Thanks.

    Thread Starter katmacau

    (@katmacau)

    Thanks. It was Transients Manager by WPBeginner that was causing the issue.

    My category page went from taking 45 seconds to 1 second to load once I disabled that plugin and the page got cached!

    Plugin Support Mirko P. woo-hc

    (@rainfallnixfig)

    I’m glad to hear you got this sorted! Thanks for letting us know what was causing the issue.

    I’ll mark this thread as resolved now. If you have any further questions, I recommend creating a new thread.

    Have a great day!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.