Support » Theme: Dyad » Category page is not working

  • Resolved pinrojas

    (@pinrojas)


    Just added the category widget to the footer and when you go to the category page, you get a message of “Page can’t be found”, even when the widget showing there’re posts linked to it.

    Thanks in advance for any help

    • This topic was modified 3 months, 3 weeks ago by pinrojas.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi there,

    Something seems to be changing the default URL structure for categories on your site, which causes the archive to produce 404 errors.

    The links in the HTML seem to be adding a period to the category URL, like https://www.cloud-native-everything.com/./automation-or-scripting/

    There a few things that could cause this.

    1. In Settings > Peramalinks > Optional, please make sure that the Category Base field is empty.

    If it isn’t, please remove any text, then click “Save Changes”.

    2. If the issue persists, please try temporarily disabling all plugins at the same time to check if it’s one of those causing the problem.

    It everything works when plugins are disabled, please try reactivating them one by one until you find the plugin that causes the problem.

    Sometimes SEO plugins can change URL structures.

    3. If the issue still persists, please try temporarily setting Permalinks back to “Plain” in Settings > Permalinks. If links work when this is done, please try setting them back to “Post Name”, then check if they still work.

    This will check if the permalinks need to be flushed, or if there’s an issue with the .htacces file.

    The option 2 works. Activated back all the required plugins and now category is working. Thanks.

    You’re welcome, gad I could help 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.