WordPress.org

Forums

"Category" not working (9 posts)

  1. MetalTiger
    Member
    Posted 10 years ago #

    Greetings, when I click one of the catagories all of the posts show up. It does not seem like the catagory feature is working.

    Any suggenstions for the MetalTiger to make this feature work? What did I do wrong? Thanks in advance.

    http://metaltiger.org

  2. NuclearMoose
    Member
    Posted 10 years ago #

    Hmm...hovering on your categories give the following:
    http://metaltiger.org/?cat= and nothing else. Have you set up the permalinks structure in your htaccess file?

    http://codex.wordpress.org/Using_Permalinks might help you.

  3. MetalTiger
    Member
    Posted 10 years ago #

    Thanks. I will look at this.

  4. MetalTiger
    Member
    Posted 10 years ago #

    Well, I have been playing around with the Permalink thing trying to set it to /%year%/%monthnum%/%day%/%postname%/

    When I go to update the .htaccess with the additional stuff starting with the:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    ect.......

    I get a Object not found Error 404 message.

    So the question is, when I update the htaccess file, do I overwrite it or just add to it. I made sure there were not any blank spaces also. Hmmmmm. Interesting this is all so new to me. What do you think there Moose?

    I tried changing the permissions on the server to 666 for the htaccess file and reloading the new Permalink structure hoping that WordPress could update the file but no luck so I changed the permissions back to where it was.

    I need help with the Permalink thing and updating the htaccess correctly. Thanks

  5. Try this:

    1. Navigate your browser to Options/Permalinks.

    2. Delete the .htaccess file via FTP.

    3. Set your new permalinks as:
    /archives/%year%/%monthnum%/%day%/%postname%/

    4. .htaccess should have been automatically created and everything should be working perfectly.

  6. MetalTiger
    Member
    Posted 10 years ago #

    Hey, thanks macmanx. It works. Very cool.

  7. sophistry
    Member
    Posted 10 years ago #

    I used the instructions here and still no category or permalinks; I kept getting 404 errors with the permalink paths - the server was trying to find the actual path and it wasn't getting changed by mod_rewrite. Then I realized: mod_rewrite can't do its job in the directory!

    I had the proper .htaccess file with all the rules in place and it still didn't work.

    Then I remembered about overrides!

    Note that you may have to add (or ask your host to add) httpd.conf overrides.
    These worked for me:

    <Directory /path/to/wordpress>
    AllowOverride Options FileInfo
    </Directory>

  8. sjk
    Member
    Posted 10 years ago #

    Big thanks for that AllowOverride tip, sophistry! I struggled too long with that last night without success but with your example and an updated "Options ... SymLinksIfOwnerMatch" directive I finally got it working on my Mac OS X system.

    Original directives:

    Options Indexes MultiViews
    AllowOverride None

    Updated directives:

    Options Indexes MultiViews SymLinksIfOwnerMatch
    AllowOverride FileInfo Options

  9. iomatic
    Member
    Posted 9 years ago #

    sophistry's post was spot-on. Thanks!

    Tiger 10.4.5

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.