Support » Theme: Cubic » Category name not showing on Category Page

  • Resolved wonderreel

    (@wonderreel)


    As the title says, the Category name has stopped showing up at the top of each Category Page (which our site uses as a kind of menu). It used to be there. In 2018, at the advice of Michael (https://wordpress.org/support/topic/modifying-category-page-header/) I modified the functions.php page so the user’s name + the category name would appear, but not the word “Category:” I used this code:

    add_filter( ‘get_the_archive_title’, function ($title) {

    if ( is_category() ) {
    $current_user = wp_get_current_user();
    if ( ($current_user instanceof WP_User) ) {
    $title = $current_user->display_name . ‘′s ‘ . single_cat_title( ”, false );
    } else {
    $title = single_cat_title( ”, false );
    }
    }

    return $title;
    });

    But now neither the user name nor the category name appears. I have tried deactivating plug-ins to no avail. Then I switched to the 2019 Theme and “Category:[name]” did show up. But when I returned to my Cubic-child Theme, the problem was still there (as well as some new problems which now require me to restore the whole site with a backup! If you go there, you’ll see–a bunch of odd little white boxes at the bottom of each page).

    Can anyone explain what might have changed, either in Cubic or in WP itself?
    Thanks!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi there,

    We can’t provide support for those kinds of modifications to a theme. I suggest posting in the general WordPress.org support forums (linked below) as there are more people watching those.

    https://wordpress.org/support/forums/

    I don’t understand. I’m not asking for support for a modification.

    The feature I’m asking about is part of the Cubic theme. The category name is supposed to be on top of the category page. Even when I deleted that code snippet, the category name doesn’t show (or in the case without the snippet “Category: Category_name” doesn’t show).

    This all worked perfectly until two weeks ago. It has nothing to do with the modification, which has been in the code for a year and a half old. And I haven’t added any new plugins (though I did test by disabling them all).

    Please help. The only thing I can imagine is that something in WP changed.

    • This reply was modified 3 months, 3 weeks ago by wonderreel.
    • This reply was modified 3 months, 3 weeks ago by wonderreel.

    Hi there,

    If I install Cubic on a test site, the category name still appears exactly as it should for me:

    News My Core Sandbox

    So I don’t see anything that indicates that a feature of Cubic has broken in any way.

    There also hasn’t been any recent updates to this theme, so the most likely explanation is that a change in WordPress Core is causing your custom code in your child theme to no longer work. I have no idea which change in Core this might have been, though.

    As @fstat indicated above, we’re not able to provide support for custom PHP modifications to our themes, so I’m not able to help you figure out exactly what’s causing this and how to fix it in this case. You can try asking in the advanced forum instead, or else at https://wordpress.stackexchange.com/

    @fstat @kokkieh Thanks for your help with this. It turns out that there was a change in WP Core 4.5, and it didn’t affect the child theme. It affected a very small code-snippet plug-in that determined which menu each role would see. Basically, it made all the role-menu relationships disappear. I tracked it down and deleted it and now things seem to be mostly ok. I’m grateful for the time and thought you put into this.

    Thanks for letting us know you figured it out.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.