WordPress.org

Support

Support » Plugins and Hacks » Category links don't work

Category links don't work

  • The category links don’t work. In other words, I have to use [link-library settings=1] instead of [link-library-cats settings=1] if I want any links to be displayed.

    When I display per category, I can click on the category link and get the URL to change to #blogroll or whatever the category is, but no additional page content gets displayed. I even tried the other 2 settings: GET and GET+Permalink.

    Thanks.

    http://wordpress.org/extend/plugins/link-library/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Same problem, any idea?

    nope

    The [ link-library ] shortcode is only for displaying links. It’s not intended for displaying categories at all.

    The [ link-library-cats ] shortcode is only for displaying cats. It’s not intended for displaying links.

    So if you want links and cats you must put both shortcodes on the page.

    I know it confused me the first time I started using link library, because I thought that [ link-library settings=1 ] would simply display everything from library 1. IT DOES NOT! A library is a “merge” of the links/cats/search settings, and the settings=x determines which library is used for that specific shortcode functionality.

    So:
    [ link-library settings=1 ] means display links and use link settings specified in library 1.

    [link-library-cats settings=2 ] means display categories and use the category settings specified in library 2.

    There’s a whole lot more to it, like using cats overrides and how search results are filtered, but the above should give you basic understanding of how the plugin operates.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Category links don't work’ is closed to new replies.