• I tried pasting all the posts of my website efinancemanagement.com to a word file but the word file did not respond to such a large “paste”.

    So, I thought, I will make it small category by category but the category filter does not work. I typed a category name but it does not search my categories.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Michael Nelson

    (@mnelson4)

    Hi Sanja, sorry to hear you’re having trouble. Those are both new problems I haven’t heard of before. Let’s see what we can do…
    Can you tell me the URL of your site? That will help me see if the problem is happening for me too, which will help a lot in identifying what’s going wrong.

    Thread Starter sanja.b

    (@sanjab)

    efinancemanagement.com

    Plugin Author Michael Nelson

    (@mnelson4)

    Hi @sanjab, sorry for the delay.

    I found the issue. iThemes is restricting access to the categories because Print My Blog wasn’t sending some security-related data.

    I have an update for Print My Blog that fixed the issue on my test website. Would you like to try it before I release the next version? If so, here’s how:

    1. Download the new version from here: https://github.com/mnelson4/printmyblog/archive/BUG/filtering-by-category-if-rest-api-restricted.zip
    2. Go to your WordPress dashboard, click plugins, then “add new”, then “upload” and select the zip file you just downloaded
    3. Deactivate the previous version Print My Blog
    4. Activate the new version of Print My Blog

    Then try to filter by category and users again. It should work now.

    If you aren’t comfortable trying it, or don’t have time, no worries, please just let me know.

    Also: how many posts are you trying to post at once? If you temporarily remove iTheme’s restricted REST API access, I can try it and see how it goes for me.

    Plugin Author Michael Nelson

    (@mnelson4)

    FYI I just released version 2.6.1 which has the fix, so to test it all you need to do is update normally.
    Thanks for reporting the issue! Let me know if you continue to have trouble once you’re on version 2.6.1.

    I’d still like to see how it goes pasting all your posts at once. My blog has about a hundred and fifty posts and it pastes ok. I’m guessing yours has a lot more?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Category Filters not Working’ is closed to new replies.