WordPress.org

Support

Support » How-To and Troubleshooting » Category and archive page not showing youtube video

Category and archive page not showing youtube video

  • I would like when I click on a category or archive page on my site that it shows the videos attached to my posts. I found other posts mentioning changing the excerpt to the content and that didn’t work. any other ideas? Feel free to take a look and let me know.

    http://wsustudio76.com/category/video/tce/

    Your help is greatly appreciated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    @esmi

    Forum Moderator

    Are your category and/or archive template files using <?php the_excerpt();>? If so, try changing that to <?php the_content();?>

    Tried this.

    <?php the_excerpt();>? If so, try changing that to <?php the_content();?>

    There’s not a single the_excerpt left in the template files I have access to.

    esmi

    @esmi

    Forum Moderator

    Added a tag to alert the theme’s author. Perhaps he can help. In the meantime, you are making any changes using a child theme, aren’t you?

    Not sure what you mean by child theme, I am extremely new to wordpress.

    esmi

    @esmi

    Forum Moderator

    You should not alter anything within the theme itself. Create a child theme for your changes.

    Understood. Will do. Hopefully the author can help. Thanks again.

    Emil Uzelac

    @emiluzelac

    Theme Review Admin

    Hi,

    Theme offers two blog Templates, one is for full posts and another one for summaries. However this isn’t tied with Blog Template, category archives are in archive.php

    As previously mentioned, first get a Child Theme in place, if you don’t know how to make one, please download a working copy from: http://themeid.com/forum/topic/505/child-theme-example/ and copy archive.php from /responsive/ to /responsive-child-theme/, open archive.php and look for:

    <?php the_excerpt(); ?>

    and change that to:

    <?php the_content(); ?>

    Thanks,
    Emil

    Ok, I’ve done both of those. It appears to still not work, but with some further investigation, I’ve found that it may have to do with the way I am getting the posts to my site. I currently use the Automatic Youtube Video Posts plugin which creates a post on my word press site any time i upload something to youtube. So these are coming in differently than one that I just put the html embed text in the post.

    Any idea on how to get the content to work the way I would like or to get the plugin to do the same.

    I’m willing to switch plugins if I need to, as long as I can make it easier on my web team to not have to spend as much time posting.

    Emil Uzelac

    @emiluzelac

    Theme Review Admin

    In that case I would contact the plugin author and get more information how to get this going. Any YouTube stuff I personally do are usually simple embeds, nothing more sorry.

    P.S. Any* time we leave a plugin to automate post creation it might not be the same as the manual process, please make a note of that 🙂

    Emil

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Category and archive page not showing youtube video’ is closed to new replies.