WordPress.org

Support

Support » How-To and Troubleshooting » Categories/Tags Not Working

Categories/Tags Not Working

Viewing 14 replies - 1 through 14 (of 14 total)
  • Michael

    @alchymyth

    Forum Moderator

    check your permalink settings http://codex.wordpress.org/Using_Permalinks

    does your theme have a archive.php, category.php or tag.php?

    if not, does the index.php contain a custom query?

    do the month or year archives work?

    if this does not help to solve your problem, please post a link to your site.

    I use a custom structure for my permalink: /%category%/%postname%/
    My theme has a category-33.php i just checked the month and year archives don’t work either.

    Michael

    @alchymyth

    Forum Moderator

    category-33.php is a category tempalte which will only get used for archives of category 33; do you have posts of category 33, and does that category archive work properly?

    no archive.php??

    what is the code in index.php?

    (please use the pastebin – see http://codex.wordpress.org/Forum_Welcome#Posting_Code )

    i don’t have an archive.php

    index.php— http://pastebin.com/fZCDyz8C

    Michael

    @alchymyth

    Forum Moderator

    this is the section in index.php, I would be calling a ‘custom query’:

    <?php
                    $temp = $wp_query;
                    $wp_query = null;
                    $wp_query = new WP_Query();
                    $wp_query->query('cat=-49,-50,-52&paged='.$paged);
    ?>

    make a copy of index.php, save it as archive.php, and remove that section from archive.php

    ok thanks i will do this. Will this fix everything? Categories/Tags and Archives?

    Michael

    @alchymyth

    Forum Moderator

    Will this fix everything? Categories/Tags and Archives?

    should do…

    it worked thanks. I had to change the pagination though b/c it was copying my 148 blog posts. So lets just say each category had 10 posts it would go through all 10, but when you click 11 you get error.

    I have 1 more question for you: http://www.acneskinsite.com/
    If you go to my website i want to exclude widgets from certain pages, i downloaded widget logic it is working great except for 1 thing. I want my FB/Twitter widget and video to only show on the homepage, but if i use the plugin and put show on homepage only it will still show up on the blog page too. I think b/c my homepage is synced with the blog for blog post updates it might not be possible, maybe if i try Manuel conditional hash it would work?

    P.S after you see my website u might think why not go to the design company, well i decided to start learning things on my own and stop paying a lot of money for something i should be able to figure out.

    Michael

    @alchymyth

    Forum Moderator

    is_home() checks for the blog page; is_front_page() for the front page;

    http://codex.wordpress.org/Conditional_Tags

    ok so is_front_page(123) will make it show only on homepage, that isnt the correct page id i just put 123

    when i typed in is_front_page(10) it removed the widget from the homepage and the blog page

    Michael

    @alchymyth

    Forum Moderator

    I am not sure what you are trying to achieve;

    is_front_page() does not use any arguments: http://codex.wordpress.org/Function_Reference/is_front_page

    ok in settings under reading: Front Page displays: A static page (select below) Front page: home Post page: go to my websites homepage: http://www.acneskinsite.com/ I’m trying to make the Fb widget twitter widget and the video only show on the homepage, but every time i try it will still show on my blog page too.

    Front Page: Home
    Post Page: Blog

    those are the settings for reading

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Categories/Tags Not Working’ is closed to new replies.
Skip to toolbar