WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Categories Widget Missing

[Resolved] Categories Widget Missing

  • Few days ago I upgraded from WP 2.51 to WP 2.8. A day after the upgrade I was changing around the Widgets and I removed the Categories Widget from the sidebar. When the screen refreshed the Widget dissapeared and now it’s gone.

    It’s not listed under Available Widgets or Inactive Widgets.

    Things I’ve tried:

    Deleted and re-uploaded the WP-Includes and WP-Admin folders
    Switched back to Default Theme
    Deactivated all plugins
    Tried both IE and Firefox (and cleared the cache from both)

    help….

Viewing 15 replies - 1 through 15 (of 33 total)
  • I have the exact same problem. I just upgraded from 2.8 to 2.8.1, and now the categories widget is missing…

    Same problem here. Update from 2.3 -> 2.8.2, category widget gone.

    Tried:
    * reinstall 2.8.2
    * deactive all plugins + reactivate
    * switch to standard theme and back
    * et cetera

    Help please 🙂

    ta-ta
    T.

    Same problem. Nothing helps.
    It exists in a brand new installation, but not in my upgraded.

    *bump*

    Come on guys, is there no input for this problem? Showing categories is one of the key points of a blog … this is just very annoying, especially since it occured *after* updating to the newest version doing everything via standard protocol et cetera .

    Thanks in advance
    Eiko

    Is there anyone out there who can help us!?!

    It’s rather bothersome not to be able to use this widget…

    I am having this exact problem and posted about it before got no responses. I’m surprised no one on this forum can help …

    Well I was unable to solve the problem so I ended up building a new WordPress install and importing all my posts using the Import function. Not very Sexy and a bit of a pain but it was the only thing I could do to fix the problem….. 🙁

    Just tried to reinstall 2.8.3 again. No change.

    Guys, there is a main widget missing when properly upgrading WP to the newest version, and this bug has existed for quite a while now.

    I mean, I did a clean reinstall, deleting all plugins, deleting all fancy stuff, getting rid of all themes. You can’t be more carefull when upgrading.

    Is this issue somehow being adressed?

    Thanks
    Eiko

    Ok guys here is the deal; the problem is not in the wordpress files, it is in the database. Any time reinstalling the files does not fix something the problem might be in the database. I’m not an expert at mySQL but I know what I am doing most of the time. You will have to know how to get into your database and edit values. The easy fix for those of you that do not have a clue when it comes to mySQL is to backup your stuff, dump the database and make a new one. It is a pain but it does work. Looks like one of the wordpress updates messed up this setting in the database making the admin interface hide the widget. I run my own server so I’m able to use the mySQL GUI Admin tools to get into my databases for problems like this. I run about 6 wordpress sites and only one of them had this problem. My fix was to copy settings from one database to the broken one and it worked; the widget popped right up.

    Ok here is what you are looking for:
    SELECT * FROM wordpress.wp_options
    WHERE option_name = ‘widget_categories’

    Edit the option_value to: a:1:{s:12:”_multiwidget”;i:1;}

    This is the default for wordpress and should make it pop back up ware you can then configure the widget.
    Feel free to ask question if you guys want more info; only took me a hour or so to come up with this fix.

    I love you.

    Will you marry me? 🙂

    <3

    ta-ta
    E.

    Well I have a girlfriend so I don’t think it will work out.

    Did this fix your problem?

    I Love you too, Admin caservers!

    Will your girlfriend marry me? 🙂

    Just kidding – thankyo very much for your effort and the solution.

    thx

    Thank you! 🙂

    I dont understand yet!

    Where I can find this

    Ok here is what you are looking for:
    SELECT * FROM wordpress.wp_options
    WHERE option_name = ‘widget_categories’

    Edit the option_value to: a:1:{s:12:”_multiwidget”;i:1;}

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Resolved] Categories Widget Missing’ is closed to new replies.
Skip to toolbar